summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-mobilephone/gammu/ChangeLog6
-rw-r--r--app-mobilephone/gammu/gammu-1.26.1-r1.ebuild87
-rw-r--r--app-mobilephone/gammu/gammu-1.27.0.ebuild92
-rw-r--r--app-mobilephone/wammu/ChangeLog5
-rw-r--r--app-mobilephone/wammu/wammu-0.32.1.ebuild60
5 files changed, 9 insertions, 241 deletions
diff --git a/app-mobilephone/gammu/ChangeLog b/app-mobilephone/gammu/ChangeLog
index 3fbae4356f10..384b63f9962a 100644
--- a/app-mobilephone/gammu/ChangeLog
+++ b/app-mobilephone/gammu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-mobilephone/gammu
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.84 2010/10/09 19:29:44 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.85 2010/12/29 21:01:24 fauli Exp $
+
+ 29 Dec 2010; Christian Faulhammer <fauli@gentoo.org>
+ -gammu-1.26.1-r1.ebuild, -gammu-1.27.0.ebuild:
+ clean up
*gammu-1.28.0 (09 Oct 2010)
diff --git a/app-mobilephone/gammu/gammu-1.26.1-r1.ebuild b/app-mobilephone/gammu/gammu-1.26.1-r1.ebuild
deleted file mode 100644
index 831d9fbd5c64..000000000000
--- a/app-mobilephone/gammu/gammu-1.26.1-r1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.26.1-r1.ebuild,v 1.4 2010/06/17 21:26:09 patrick Exp $
-
-EAPI="2"
-
-inherit eutils cmake-utils distutils
-
-DESCRIPTION="a fork of the gnokii project, a tool to handle your cellular phone"
-HOMEPAGE="http://www.gammu.org"
-SRC_URI="http://dl.cihar.com/gammu/releases/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="curl debug bluetooth irda mysql postgres dbi nls python usb"
-
-RDEPEND="bluetooth? ( net-wireless/bluez )
- curl? ( net-misc/curl )
- usb? ( dev-libs/libusb:1 )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-server )
- dbi? ( >=dev-db/libdbi-0.8.3 )
- dev-util/dialog
- dev-lang/python
- !dev-python/python-gammu" # needs to be removed from the tree
-DEPEND="${RDEPEND}
- irda? ( virtual/os-headers )
- nls? ( sys-devel/gettext )
- dev-util/cmake"
-
-# sys-devel/gettext is needed for creating .mo files
-# Supported languages and translated documentation
-# Be sure all languages are prefixed with a single space!
-MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl pt_BR ru sk sv sw zh_CN zh_TW"
-IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-skip-locktest.patch
-
- local lang support_linguas=no
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if use linguas_${lang} ; then
- support_linguas=yes
- break
- fi
- done
- # install all languages when all selected LINGUAS aren't supported
- if [ "${support_linguas}" = "yes" ]; then
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if ! use linguas_${lang} ; then
- rm -rf locale/${lang} || die
- fi
- done
- fi
-}
-
-src_configure() {
- # debug flag is used inside cmake-utils.eclass
- local mycmakeargs="$(cmake-utils_use_with bluetooth Bluez) \
- $(cmake-utils_use_with irda IRDA) \
- $(cmake-utils_use_with curl CURL) \
- $(cmake-utils_use_with usb USB) \
- $(cmake-utils_use_with python PYTHON) \
- $(cmake-utils_use_with mysql MySQL) \
- $(cmake-utils_use_with postgres Postgres) \
- $(cmake-utils_use_with dbi LibDBI) \
- $(cmake-utils_use_with nls GettextLibs) \
- $(cmake-utils_use_with nls Iconv) \
- -DBUILD_SHARED_LIBS=ON -DINSTALL_DOC_DIR=share/doc/${PF}"
- if use python; then
- mycmakeargs="${mycmakeargs} -DBUILD_PYTHON=/usr/bin/python"
- fi
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_test() {
- LD_LIBRARY_PATH="${WORKDIR}"/${PN}_build/common cmake-utils_src_test
-}
-
-src_install() {
- cmake-utils_src_install
-}
diff --git a/app-mobilephone/gammu/gammu-1.27.0.ebuild b/app-mobilephone/gammu/gammu-1.27.0.ebuild
deleted file mode 100644
index c87f7de036b7..000000000000
--- a/app-mobilephone/gammu/gammu-1.27.0.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.27.0.ebuild,v 1.5 2010/06/17 21:26:09 patrick Exp $
-
-EAPI="2"
-
-PYTHON_DEPEND="python? 2"
-
-inherit eutils cmake-utils distutils
-
-DESCRIPTION="a fork of the gnokii project, a tool to handle your cellular phone"
-HOMEPAGE="http://www.gammu.org"
-SRC_URI="http://dl.cihar.com/gammu/releases/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="curl debug bluetooth irda mysql postgres dbi nls python usb"
-
-RDEPEND="bluetooth? ( net-wireless/bluez )
- curl? ( net-misc/curl )
- usb? ( dev-libs/libusb:1 )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-server )
- dbi? ( >=dev-db/libdbi-0.8.3 )
- dev-util/dialog
- !dev-python/python-gammu" # needs to be removed from the tree
-DEPEND="${RDEPEND}
- irda? ( virtual/os-headers )
- nls? ( sys-devel/gettext )
- dev-util/cmake"
-
-# sys-devel/gettext is needed for creating .mo files
-# Supported languages and translated documentation
-# Be sure all languages are prefixed with a single space!
-MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl pt_BR ru sk sv sw zh_CN zh_TW"
-IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-skip-locktest.patch
-
- local lang support_linguas=no
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if use linguas_${lang} ; then
- support_linguas=yes
- break
- fi
- done
- # install all languages when all selected LINGUAS aren't supported
- if [ "${support_linguas}" = "yes" ]; then
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if ! use linguas_${lang} ; then
- rm -rf locale/${lang} || die
- fi
- done
- fi
-}
-
-src_configure() {
- # debug flag is used inside cmake-utils.eclass
- local mycmakeargs="$(cmake-utils_use_with bluetooth Bluez) \
- $(cmake-utils_use_with irda IRDA) \
- $(cmake-utils_use_with curl CURL) \
- $(cmake-utils_use_with usb USB) \
- $(cmake-utils_use_with python PYTHON) \
- $(cmake-utils_use_with mysql MySQL) \
- $(cmake-utils_use_with postgres Postgres) \
- $(cmake-utils_use_with dbi LibDBI) \
- $(cmake-utils_use_with nls GettextLibs) \
- $(cmake-utils_use_with nls Iconv) \
- -DBUILD_SHARED_LIBS=ON -DINSTALL_DOC_DIR=share/doc/${PF}"
- if use python; then
- mycmakeargs="${mycmakeargs} -DBUILD_PYTHON=$(PYTHON -a)"
- fi
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_test() {
- LD_LIBRARY_PATH="${WORKDIR}"/${PN}_build/common cmake-utils_src_test
-}
-
-src_install() {
- cmake-utils_src_install
-}
diff --git a/app-mobilephone/wammu/ChangeLog b/app-mobilephone/wammu/ChangeLog
index 5fda413cea27..fb1ca7431118 100644
--- a/app-mobilephone/wammu/ChangeLog
+++ b/app-mobilephone/wammu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-mobilephone/wammu
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.45 2010/12/29 20:56:05 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.46 2010/12/29 20:58:00 fauli Exp $
+
+ 29 Dec 2010; Christian Faulhammer <fauli@gentoo.org> -wammu-0.32.1.ebuild:
+ clean up
*wammu-0.35 (29 Dec 2010)
diff --git a/app-mobilephone/wammu/wammu-0.32.1.ebuild b/app-mobilephone/wammu/wammu-0.32.1.ebuild
deleted file mode 100644
index 74ac73847af1..000000000000
--- a/app-mobilephone/wammu/wammu-0.32.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/wammu-0.32.1.ebuild,v 1.1 2010/02/01 21:55:28 fauli Exp $
-
-EAPI="2"
-
-inherit distutils
-
-DESCRIPTION="front-end for gammu (Nokia and other mobiles)"
-HOMEPAGE="http://www.cihar.com/gammu/wammu/"
-SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="bluetooth"
-
-RDEPEND=">=app-mobilephone/gammu-1.25.0[python]
- >=dev-python/wxpython-2.8
- bluetooth? (
- || (
- dev-python/pybluez
- net-wireless/gnome-bluetooth
- )
- )"
-DEPEND="${RDEPEND}"
-
-# Supported languages and translated documentation
-# Be sure all languages are prefixed with a single space!
-MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl pt_BR ru sk sv zh_CN zh_TW"
-IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
-
-src_prepare() {
- local lang support_linguas=no
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if use linguas_${lang} ; then
- support_linguas=yes
- break
- fi
- done
- # install all languages when all selected LINGUAS aren't supported
- if [ "${support_linguas}" = "yes" ]; then
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if ! use linguas_${lang} ; then
- rm -r locale/${lang} || die
- fi
- done
- fi
-}
-
-src_compile() {
- # SKIPWXCHECK: else 'import wx' results in
- # Xlib: connection to ":0.0" refused by server
- SKIPWXCHECK=yes distutils_src_compile
-}
-
-src_install() {
- DOCS="AUTHORS FAQ"
- SKIPWXCHECK=yes distutils_src_install
-}