summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-zope/zope-componentvocabulary/ChangeLog10
-rw-r--r--net-zope/zope-componentvocabulary/Manifest4
-rw-r--r--net-zope/zope-componentvocabulary/metadata.xml6
-rw-r--r--net-zope/zope-componentvocabulary/zope-componentvocabulary-1.0.ebuild34
4 files changed, 54 insertions, 0 deletions
diff --git a/net-zope/zope-componentvocabulary/ChangeLog b/net-zope/zope-componentvocabulary/ChangeLog
new file mode 100644
index 000000000000..547f18cb2afb
--- /dev/null
+++ b/net-zope/zope-componentvocabulary/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zope-componentvocabulary
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-componentvocabulary/ChangeLog,v 1.1 2009/12/05 02:07:29 arfrever Exp $
+
+*zope-componentvocabulary-1.0 (05 Dec 2009)
+
+ 05 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zope-componentvocabulary-1.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/zope-componentvocabulary/Manifest b/net-zope/zope-componentvocabulary/Manifest
new file mode 100644
index 000000000000..c0e2a809d2d1
--- /dev/null
+++ b/net-zope/zope-componentvocabulary/Manifest
@@ -0,0 +1,4 @@
+DIST zope.componentvocabulary-1.0.tar.gz 7098 RMD160 c98be41dba5c7336d77cc4752173502e5e7ef541 SHA1 2f7ebff167691b8bc69fcc125fac0b256620de8f SHA256 c94533bb399a1e00b7f3664dfe0a7b07bb62578fbca148f307605931750ac955
+EBUILD zope-componentvocabulary-1.0.ebuild 872 RMD160 6f8417b83e383a44e0eaa763b3d60557fb6aabfb SHA1 732126979a3ca2498c8eb7423153ccb40f59d908 SHA256 63cbe3b3ea68f2d1182d0faa867f80b77f9554a6598fc30fd5088321a65e9bb2
+MISC ChangeLog 457 RMD160 ddb93a39cf0f94baef85e29fe9240973f13cf240 SHA1 ff9920a48d6cf133173e16e369a184ebaa38c496 SHA256 1704f86994e10484caaf8d69d36cd894ae8c4789e48c11247e4ec08166589b1c
+MISC metadata.xml 183 RMD160 0e2d86898897ee70cc1f6e9ceb76d00388d3b2fa SHA1 19635a9dfa15036e341a7cbdd8cbd018db62be82 SHA256 f480763451083d2f7be8fc23d38e02952ccc383b4cc65e103a9901a0907ce50d
diff --git a/net-zope/zope-componentvocabulary/metadata.xml b/net-zope/zope-componentvocabulary/metadata.xml
new file mode 100644
index 000000000000..ecc751f37510
--- /dev/null
+++ b/net-zope/zope-componentvocabulary/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/net-zope/zope-componentvocabulary/zope-componentvocabulary-1.0.ebuild b/net-zope/zope-componentvocabulary/zope-componentvocabulary-1.0.ebuild
new file mode 100644
index 000000000000..531480365d63
--- /dev/null
+++ b/net-zope/zope-componentvocabulary/zope-componentvocabulary-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-componentvocabulary/zope-componentvocabulary-1.0.ebuild,v 1.1 2009/12/05 02:07:29 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Component vocabularies"
+HOMEPAGE="http://pypi.python.org/pypi/zope.componentvocabulary"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-zope/zope-component
+ net-zope/zope-i18nmessageid
+ net-zope/zope-interface
+ net-zope/zope-schema
+ net-zope/zope-security"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN/-//}"
+DOCS="CHANGES.txt README.txt"