summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/simpletal/ChangeLog8
-rw-r--r--dev-python/simpletal/simpletal-4.2.ebuild11
-rw-r--r--dev-python/simpletal/simpletal-5.0.ebuild11
3 files changed, 16 insertions, 14 deletions
diff --git a/dev-python/simpletal/ChangeLog b/dev-python/simpletal/ChangeLog
index c12788ef2cba..c777e45ef8ff 100644
--- a/dev-python/simpletal/ChangeLog
+++ b/dev-python/simpletal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/simpletal
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/ChangeLog,v 1.8 2009/11/22 19:32:06 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/ChangeLog,v 1.9 2010/06/29 04:39:57 arfrever Exp $
+
+ 29 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ simpletal-4.2.ebuild, simpletal-5.0.ebuild:
+ Use PYTHON_DEPEND instead of NEED_PYTHON.
*simpletal-5.0 (22 Nov 2009)
*simpletal-4.2 (22 Nov 2009)
diff --git a/dev-python/simpletal/simpletal-4.2.ebuild b/dev-python/simpletal/simpletal-4.2.ebuild
index 9455a274c279..6a2f1055322d 100644
--- a/dev-python/simpletal/simpletal-4.2.ebuild
+++ b/dev-python/simpletal/simpletal-4.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/simpletal-4.2.ebuild,v 1.1 2009/11/22 19:32:06 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/simpletal-4.2.ebuild,v 1.2 2010/06/29 04:39:57 arfrever Exp $
-EAPI="2"
-
-NEED_PYTHON="2.5"
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
inherit distutils
@@ -23,7 +23,6 @@ IUSE="examples"
DEPEND="dev-python/pyxml"
RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/simpletal/simpletal-5.0.ebuild b/dev-python/simpletal/simpletal-5.0.ebuild
index 741cb86e8498..5ab09aa83fa5 100644
--- a/dev-python/simpletal/simpletal-5.0.ebuild
+++ b/dev-python/simpletal/simpletal-5.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/simpletal-5.0.ebuild,v 1.1 2009/11/22 19:32:06 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/simpletal-5.0.ebuild,v 1.2 2010/06/29 04:39:57 arfrever Exp $
-EAPI="2"
-
-NEED_PYTHON="3.0"
+EAPI="3"
+PYTHON_DEPEND="3"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.*"
inherit distutils
@@ -23,7 +23,6 @@ IUSE="examples"
DEPEND=""
RDEPEND=""
-RESTRICT_PYTHON_ABIS="2.*"
S="${WORKDIR}/${MY_P}"