summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/equo/ChangeLog7
-rw-r--r--app-admin/equo/equo-1.0_rc29.ebuild44
-rw-r--r--app-admin/sulfur/ChangeLog7
-rw-r--r--app-admin/sulfur/sulfur-1.0_rc29.ebuild51
4 files changed, 107 insertions, 2 deletions
diff --git a/app-admin/equo/ChangeLog b/app-admin/equo/ChangeLog
index 4097bb16a458..9e061ddf9978 100644
--- a/app-admin/equo/ChangeLog
+++ b/app-admin/equo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/equo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.2 2011/07/19 12:38:04 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.3 2011/08/02 16:54:55 lxnay Exp $
+
+*equo-1.0_rc29 (02 Aug 2011)
+
+ 02 Aug 2011; Fabio Erculiani <lxnay@gentoo.org> +equo-1.0_rc29.ebuild:
+ version bump
19 Jul 2011; Fabio Erculiani <lxnay@gentoo.org> equo-1.0_rc27.ebuild:
update DESCRIPTION
diff --git a/app-admin/equo/equo-1.0_rc29.ebuild b/app-admin/equo/equo-1.0_rc29.ebuild
new file mode 100644
index 000000000000..d31445acbd03
--- /dev/null
+++ b/app-admin/equo/equo-1.0_rc29.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-1.0_rc29.ebuild,v 1.1 2011/08/02 16:54:55 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils multilib python bash-completion
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="~sys-apps/entropy-${PV}"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/$(get_libdir)" equo-install || die "make install failed"
+ dobashcompletion "${S}/misc/equo-completion.bash" equo
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/$(get_libdir)/entropy/client"
+ bash-completion_pkg_postinst
+ echo
+ elog "If you would like to allow users in the 'entropy' group"
+ elog "to update available package repositories, please consider"
+ elog "to install sys-apps/entropy-client-services"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/$(get_libdir)/entropy/client"
+}
diff --git a/app-admin/sulfur/ChangeLog b/app-admin/sulfur/ChangeLog
index d8aaf01b551a..7d8dff9cd6c0 100644
--- a/app-admin/sulfur/ChangeLog
+++ b/app-admin/sulfur/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/sulfur
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sulfur/ChangeLog,v 1.1 2011/07/19 12:47:28 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sulfur/ChangeLog,v 1.2 2011/08/02 16:55:15 lxnay Exp $
+
+*sulfur-1.0_rc29 (02 Aug 2011)
+
+ 02 Aug 2011; Fabio Erculiani <lxnay@gentoo.org> +sulfur-1.0_rc29.ebuild:
+ version bump
*sulfur-1.0_rc27 (19 Jul 2011)
diff --git a/app-admin/sulfur/sulfur-1.0_rc29.ebuild b/app-admin/sulfur/sulfur-1.0_rc29.ebuild
new file mode 100644
index 000000000000..6b86be566c5e
--- /dev/null
+++ b/app-admin/sulfur/sulfur-1.0_rc29.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sulfur/sulfur-1.0_rc29.ebuild,v 1.1 2011/08/02 16:55:15 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils gnome2-utils fdo-mime python
+
+DESCRIPTION="Sulfur, the Entropy Package Manager Store"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+S="${WORKDIR}/entropy-${PV}/sulfur"
+
+RDEPEND=">=dev-python/pygtk-2.12.1-r2
+ ~sys-apps/entropy-${PV}
+ sys-apps/file[python]
+ sys-devel/gettext
+ >=x11-libs/vte-0.12.2[python]
+ x11-misc/xdg-utils"
+DEPEND="sys-devel/gettext"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/$(get_libdir)" install || die "make install failed"
+ dodir /etc/gconf/schemas
+ insinto /etc/gconf/schemas
+ doins "${S}/misc/entropy-handler.schemas"
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ gnome2_gconf_savelist
+ gnome2_gconf_install
+ python_mod_optimize "/usr/$(get_libdir)/entropy/${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/$(get_libdir)/entropy/${PN}"
+ gnome2_gconf_savelist
+ gnome2_gconf_uninstall
+}