summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/krb5/krb5-1.2.5-r1.ebuild')
-rw-r--r--app-crypt/krb5/krb5-1.2.5-r1.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/app-crypt/krb5/krb5-1.2.5-r1.ebuild b/app-crypt/krb5/krb5-1.2.5-r1.ebuild
index 16a0c20e2bab..91a549b510f7 100644
--- a/app-crypt/krb5/krb5-1.2.5-r1.ebuild
+++ b/app-crypt/krb5/krb5-1.2.5-r1.ebuild
@@ -1,35 +1,37 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5-r1.ebuild,v 1.5 2002/10/04 03:57:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5-r1.ebuild,v 1.6 2002/11/30 20:33:36 vapier Exp $
-S=${WORKDIR}/${P}/src
SRC_URI="http://www.crypto-publish.org/dist/mit-kerberos5/${P}.tar.gz"
DESCRIPTION="MIT Kerberos V (set up for pam)"
-HOMEPAGE="http://crypto-publish.org"
+HOMEPAGE="http://crypto-publish.org/"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
-DEPEND="virtual/glibc"
+S=${WORKDIR}/${P}/src
src_compile() {
-
patch -p0 < ${FILESDIR}/${PN}-1.2.2-gentoo.diff || die
econf \
--with-krb4 \
--enable-shared \
- --enable-dns || die
+ --enable-dns
+
mv Makefile Makefile.orig
#Don't install the ftp, telnet, r* apps; use pam instead
sed -e 's/ appl / /' Makefile.orig > Makefile
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
cd ..
dodoc README
- echo 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
+}
+
+pkg_postinst() {
+ ewarn 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
}