summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/xca/xca-0.6.4.ebuild')
-rw-r--r--app-crypt/xca/xca-0.6.4.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/app-crypt/xca/xca-0.6.4.ebuild b/app-crypt/xca/xca-0.6.4.ebuild
deleted file mode 100644
index 47262adf7a01..000000000000
--- a/app-crypt/xca/xca-0.6.4.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.6.4.ebuild,v 1.8 2009/12/16 15:53:56 ssuominen Exp $
-
-EAPI="1"
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="A graphical user interface to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
-HOMEPAGE="http://www.hohnstaedt.de/xca.html"
-SRC_URI="mirror://sourceforge/xca/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="doc"
-
-RDEPEND=">=dev-libs/openssl-0.9.8
- x11-libs/qt-gui:4"
-DEPEND="${RDEPEND}
- doc? ( app-text/linuxdoc-tools )"
-
-# Upstream:
-# http://sourceforge.net/tracker/index.php?func=detail&aid=1800298&group_id=62274&atid=500028
-#
-# 1. Qt detection.
-# 2. doc hacks.
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-build.patch"
- epatch "${FILESDIR}/${P}-openssl.patch"
-}
-
-src_compile() {
- local LINUXDOC
- use doc || LINUXDOC='touch $@ && true'
-
- QTDIR=/usr \
- STRIP="true" \
- LINUXDOC="${LINUXDOC}" \
- CC="$(tc-getCC)" \
- LD="$(tc-getLD)" \
- LDFLAGS="$(raw-ldflags)" \
- prefix=/usr \
- ./configure || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake destdir="${D}" mandir="share/man" install || die "install failed"
-
- dodoc AUTHORS
-
- insinto /etc/xca
- doins misc/*.txt
-}