summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs/emacs-21.4-r6.ebuild')
-rw-r--r--app-editors/emacs/emacs-21.4-r6.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/app-editors/emacs/emacs-21.4-r6.ebuild b/app-editors/emacs/emacs-21.4-r6.ebuild
index 2e3e5b532332..38a475557e14 100644
--- a/app-editors/emacs/emacs-21.4-r6.ebuild
+++ b/app-editors/emacs/emacs-21.4-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r6.ebuild,v 1.5 2007/02/04 14:54:31 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r6.ebuild,v 1.6 2007/02/06 06:09:41 opfer Exp $
inherit flag-o-matic eutils alternatives toolchain-funcs
@@ -160,10 +160,7 @@ src_install() {
update-alternatives() {
# extract the suffix of the manpages to determine the correct compression program
- local suffix=".`ls /usr/share/man/man1/emacs.emacs-* |sed s/".*\."//g|tail -n 1`"
- if [ suffix = 1 ]; then
- suffix=""
- fi
+ local suffix=$(echo /usr/share/man/man1/emacs.emacs-*.1*|sed 's/.*\.1//')
# this creates symlinks for binaries and man pages, so the correct ones in a slotted
# environment can be accessed
@@ -172,7 +169,7 @@ update-alternatives() {
alternatives_auto_makesym "/usr/bin/$i" "/usr/bin/${i}.emacs-*"
done
- for j in emacs emacsclient etags ctags
+ for j in emacs etags ctags gfdl
do
alternatives_auto_makesym "/usr/share/man/man1/$j.1${suffix}" "/usr/share/man/man1/$j.emacs-*"
done