summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/vm/vm-8.0.12-r3.ebuild')
-rw-r--r--app-emacs/vm/vm-8.0.12-r3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-emacs/vm/vm-8.0.12-r3.ebuild b/app-emacs/vm/vm-8.0.12-r3.ebuild
new file mode 100644
index 000000000000..fbfb0de26741
--- /dev/null
+++ b/app-emacs/vm/vm-8.0.12-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/vm-8.0.12-r3.ebuild,v 1.1 2009/09/10 08:32:36 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="The VM mail reader for Emacs"
+HOMEPAGE="http://www.nongnu.org/viewmail/"
+SRC_URI="http://download.savannah.nongnu.org/releases/viewmail/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="bbdb ssl"
+
+DEPEND="bbdb? ( app-emacs/bbdb )"
+RDEPEND="${DEPEND}
+ ssl? ( net-misc/stunnel )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-autoload-vm-pine.patch" #246185
+ epatch "${FILESDIR}/${P}-supercite-yank.patch" #256886
+
+ if ! use bbdb; then
+ elog "Excluding vm-pcrisis.el since the \"bbdb\" USE flag is not set."
+ epatch "${FILESDIR}/vm-8.0-no-pcrisis.patch"
+ fi
+
+ # fix vm-version, bug 235563
+ #sed -i -e "/^(defvar vm-version /s/nil/\"${PV}\"/" lisp/vm-version.el \
+ # || die "sed failed"
+}
+
+src_compile() {
+ econf \
+ --with-emacs="emacs" \
+ --with-pixmapdir="${SITEETC}/${PN}" \
+ $(use bbdb && echo "--with-other-dirs=${SITELISP}/bbdb") \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc NEWS README TODO example.vm || die "dodoc failed"
+}