summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-1.3.1.ebuild')
-rw-r--r--app-emulation/wine/wine-1.3.1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/app-emulation/wine/wine-1.3.1.ebuild b/app-emulation/wine/wine-1.3.1.ebuild
index ae8f87d64dc3..1b5bab8583fd 100644
--- a/app-emulation/wine/wine-1.3.1.ebuild
+++ b/app-emulation/wine/wine-1.3.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.1.ebuild,v 1.16 2011/12/02 23:32:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.1.ebuild,v 1.17 2012/01/14 03:20:51 tetromino Exp $
-EAPI="2"
+EAPI="4"
inherit eutils flag-o-matic multilib
@@ -26,7 +26,8 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa capi cups custom-cflags dbus esd fontconfig +gecko gnutls gphoto2 gsm hardened jack jpeg lcms ldap mp3 nas ncurses openal +opengl +oss +perl png samba scanner ssl test +threads +truetype v4l +win32 +win64 +X xcomposite xinerama xml"
+IUSE="alsa capi cups custom-cflags dbus elibc_glibc fontconfig +gecko gnutls gphoto2 gsm hardened jack jpeg lcms ldap mp3 nas ncurses openal +opengl +oss +perl png samba scanner ssl test +threads +truetype v4l +win32 +win64 +X xcomposite xinerama xml"
+REQUIRED_USE="elibc_glibc? ( threads )"
RESTRICT="test" #72375
MLIB_DEPS="amd64? (
@@ -63,7 +64,6 @@ RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
)
xinerama? ( x11-libs/libXinerama )
alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
nas? ( media-libs/nas )
cups? ( net-print/cups )
opengl? ( virtual/opengl )
@@ -125,7 +125,7 @@ do_configure() {
$(use_with lcms cms) \
$(use_with cups) \
$(use_with ncurses curses) \
- $(use_with esd) \
+ --without-esd \
$(use_with fontconfig) \
$(use_with gnutls) \
$(use_with gphoto2 gphoto) \
@@ -153,7 +153,7 @@ do_configure() {
$(use_with xml xslt) \
$2
- emake -j1 depend || die "depend"
+ emake -j1 depend
popd >/dev/null
}
@@ -174,7 +174,7 @@ src_compile() {
for b in 64 32 ; do
local builddir="${WORKDIR}/wine${b}"
[[ -d ${builddir} ]] || continue
- emake -C "${builddir}" all || die
+ emake -C "${builddir}" all
done
}
@@ -183,7 +183,7 @@ src_install() {
for b in 64 32 ; do
local builddir="${WORKDIR}/wine${b}"
[[ -d ${builddir} ]] || continue
- emake -C "${builddir}" install DESTDIR="${D}" || die
+ emake -C "${builddir}" install DESTDIR="${D}"
done
dodoc ANNOUNCE AUTHORS README
if use gecko ; then