summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-1.3.29.ebuild')
-rw-r--r--app-emulation/wine/wine-1.3.29.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/app-emulation/wine/wine-1.3.29.ebuild b/app-emulation/wine/wine-1.3.29.ebuild
index 30ab296ddb94..e99fd7392821 100644
--- a/app-emulation/wine/wine-1.3.29.ebuild
+++ b/app-emulation/wine/wine-1.3.29.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.29.ebuild,v 1.3 2011/12/20 19:35:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.29.ebuild,v 1.4 2012/01/14 03:20:51 tetromino Exp $
-EAPI="2"
+EAPI="4"
inherit eutils flag-o-matic multilib
@@ -29,7 +29,8 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa capi cups custom-cflags dbus fontconfig +gecko gnutls gphoto2 gsm gstreamer hardened jpeg lcms ldap mp3 ncurses nls openal opencl +opengl +oss +perl png samba scanner ssl test +threads +truetype v4l +win32 +win64 +X xcomposite xinerama xml"
+IUSE="alsa capi cups custom-cflags dbus elibc_glibc fontconfig +gecko gnutls gphoto2 gsm gstreamer hardened jpeg lcms ldap mp3 ncurses nls openal opencl +opengl +oss +perl png samba scanner ssl test +threads +truetype v4l +win32 +win64 +X xcomposite xinerama xml"
+REQUIRED_USE="elibc_glibc? ( threads )" #286560
RESTRICT="test" #72375
MLIB_DEPS="amd64? (
@@ -156,7 +157,7 @@ do_configure() {
$(use_with xml xslt) \
$2
- emake -j1 depend || die "depend"
+ emake -j1 depend
popd >/dev/null
}
@@ -177,7 +178,7 @@ src_compile() {
for b in 64 32 ; do
local builddir="${WORKDIR}/wine${b}"
[[ -d ${builddir} ]] || continue
- emake -C "${builddir}" all || die
+ emake -C "${builddir}" all
done
}
@@ -186,13 +187,13 @@ src_install() {
for b in 64 32 ; do
local builddir="${WORKDIR}/wine${b}"
[[ -d ${builddir} ]] || continue
- emake -C "${builddir}" install DESTDIR="${D}" || die
+ emake -C "${builddir}" install DESTDIR="${D}"
done
dodoc ANNOUNCE AUTHORS README
if use gecko ; then
insinto /usr/share/wine/gecko
- doins "${DISTDIR}"/wine_gecko-${GV}-x86.msi || die
- use win64 && { doins "${DISTDIR}"/wine_gecko-${GV}-x86_64.msi || die ; }
+ doins "${DISTDIR}"/wine_gecko-${GV}-x86.msi
+ use win64 && doins "${DISTDIR}"/wine_gecko-${GV}-x86_64.msi
fi
if ! use perl ; then
rm "${D}"/usr/bin/{wine{dump,maker},function_grep.pl} "${D}"/usr/share/man/man1/wine{dump,maker}.1 || die