summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog32
-rw-r--r--app-emulation/wine/files/digest-wine-20020904-r11
-rw-r--r--app-emulation/wine/wine-20020904-r1.ebuild106
-rw-r--r--app-emulation/winex-cvs/ChangeLog23
-rw-r--r--app-emulation/winex-cvs/winex-cvs-2.0.ebuild14
-rw-r--r--app-emulation/winex-cvs/winex-cvs-2.1.ebuild11
-rw-r--r--app-emulation/winex/ChangeLog19
-rw-r--r--app-emulation/winex/files/digest-winex-20020807-r12
-rw-r--r--app-emulation/winex/winex-20020807-r1.ebuild118
-rw-r--r--app-emulation/winex/winex-20020807.ebuild4
10 files changed, 300 insertions, 30 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index b9f50b47ee9d..7c541075b36e 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,10 +1,17 @@
# ChangeLog for app-emulation/wine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.18 2002/09/09 19:33:57 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.19 2002/09/13 14:48:23 phoenix Exp $
-*wine-20020809 (09 Sep 2002)
+*wine-20020904-r1 (13 Sep 2002)
- 09 Sep 2002; phoen][x <phoenix@gentoo.org> wine-20020809.ebuild :
+ 13 Sep 2002; phoen][x <phoenix@gentoo.org> wine-20020904-r1.ebuild, ChangeLog :
+
+ Added manpage installation. This installs the manpage of wine as ${PN}.
+ Tidied up the ChangeLog.
+
+*wine-20020904 (09 Sep 2002)
+
+ 09 Sep 2002; phoen][x <phoenix@gentoo.org> wine-20020904.ebuild :
Bumped to new version.
@@ -36,19 +43,22 @@
Updated ebuild so it installs /usr/wine/bin/regapi. Closes bug #5611.
18 Jun 2002; Michael Cohen <mjc@gentoo.org> wine-20020710.ebuild :
+
Added ALSA and arts dependencies (Bug #5206 and friends)
-*wine-20020710 (17 Jun 2002)
- 17 Jun 2002 ;Michael Cohen <mjc@gentoo.org> wine-20020710.ebuild :
- Version bump
+*wine-20020710 (17 Jun 2002)
+ 17 Jun 2002; Michael Cohen <mjc@gentoo.org> wine-20020710.ebuild :
+
+ Version bump
*wine-20020605-r2 (15 Jun 2002)
- 15 Jun 2002 ;Spider <spider@gentoo.org> wine-20020605-r2.ebuild :
- the /etc/wine stuff wasn't installed so I fixed that (seems the source had moved into documentation/samples )
+ 15 Jun 2002; Spider <spider@gentoo.org> wine-20020605-r2.ebuild :
+
+ the /etc/wine stuff wasn't installed so I fixed that
+ (seems the source had moved into documentation/samples)
-
*wine-20020605-r1 (14 Jun 2002)
14 Jun 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
@@ -69,7 +79,6 @@
14 Apr 2002; Dan Armak <danarmak@gentoo.org>: new upstream release
-
*wine-20020310-r1 (29 Mar 2002)
29 Mar 2002; Dan Armak <danarmak@gentoo.org>: fix bug #1373: disable custom optimizations,
@@ -82,8 +91,7 @@
man page/LFH fix submitted by Matthew Kennedy.
-
-22 Mar 2002; Dan Armak <danarmak@gentoo.org> Add missing /etc/wine/winedefault.reg file.
+ 22 Mar 2002; Dan Armak <danarmak@gentoo.org> Add missing /etc/wine/winedefault.reg file.
*wine-20020310 (12 Mar 2002)
diff --git a/app-emulation/wine/files/digest-wine-20020904-r1 b/app-emulation/wine/files/digest-wine-20020904-r1
new file mode 100644
index 000000000000..4d9267244b7f
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20020904-r1
@@ -0,0 +1 @@
+MD5 686ebc4cb0a9ba3202e15453b07ab69a Wine-20020904.tar.gz 7603556
diff --git a/app-emulation/wine/wine-20020904-r1.ebuild b/app-emulation/wine/wine-20020904-r1.ebuild
new file mode 100644
index 000000000000..24c4f6b6774a
--- /dev/null
+++ b/app-emulation/wine/wine-20020904-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20020904-r1.ebuild,v 1.1 2002/09/13 14:48:23 phoenix Exp $
+
+DESCRIPTION="Wine is a free implementation of Windows on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+DEPEND="virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ dev-lang/tcl dev-lang/tk
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )"
+
+src_compile() {
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ # the folks at #winehq were really angry about custom optimization
+ export CFLAGS=""
+ export CXXFLAGS=""
+
+ ./configure --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+
+}
+
+src_install () {
+
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ cd ${S}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Creates /usr/lib/wine/.data with fake_windows in it
+ # This is needed for our wine wrapper script
+ mkdir ${D}/usr/lib/wine/.data
+ cp -R ${WORKDIR}/fake_windows ${D}/usr/lib/wine/.data
+ cp ${FILESDIR}/${P}-config ${D}/usr/lib/wine/.data/config
+ cp ${WORKDIR}/${P}/winedefault.reg ${D}/usr/lib/wine/.data/winedefault.reg
+
+ # Install the wrapper script
+ mkdir ${D}/usr/bin
+ cp ${FILESDIR}/${P}-wine ${D}/usr/bin/wine
+ cp ${FILESDIR}/${P}-regedit ${D}/usr/bin/regedit-wine
+
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ insinto /usr/lib/wine/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/wine/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "**********************************************************************"
+ einfo "* NOTE: Use /usr/bin/wine to start wine. This is a wrapper-script *"
+ einfo "* which will take care of everything else. *"
+ einfo "* Use /usr/bin/regedit-wine to import registry files into the *"
+ einfo "* wine registry. *"
+ einfo "* If you have further questions, enhancements or patches *"
+ einfo "* send an email to phoenix@gentoo.org *"
+ einfo "* *"
+ einfo "* Manpage has been installed to the system. *"
+ einfo "* \"man wine\" should show it. *"
+ einfo "**********************************************************************"
+}
+
diff --git a/app-emulation/winex-cvs/ChangeLog b/app-emulation/winex-cvs/ChangeLog
index d36bc4f4090f..7f8c42a70aff 100644
--- a/app-emulation/winex-cvs/ChangeLog
+++ b/app-emulation/winex-cvs/ChangeLog
@@ -1,14 +1,17 @@
# ChangeLog for app-emulation/winex-cvs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/ChangeLog,v 1.4 2002/09/13 11:46:55 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/ChangeLog,v 1.5 2002/09/13 14:51:07 phoenix Exp $
- 13 Sep 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+*winex-cvs-2.1 (08 September 20002)
- Fix issue discussed in comments of bug #7319 where dev-util/cvs was missing
- from the dep list.
+ 13 Sep 2002; phoen][x <phoenix@gentoo.org> winex-cvs-2.1.ebuild :
+ Added manpage installation. This installs the manpage of wine as ${PN}.
-*winex-cvs-2.1 (08 September 20002)
+ 13 Sep 2002; Dan Armak <danarmak@gentoo.org> winex-cvs-2.1.ebuild :
+
+ Fix issue discussed in comments of bug #7319 where dev-util/cvs was missing
+ from the dep list.
08 Sep 2002; phoen][x <phoenix@gentoo.org> winex-cvs-2.1.ebuild,
files/digest-winex-cvs-2.1, files/winex-cvs-fake_windows.tar.bz2,
@@ -22,6 +25,16 @@
*winex-cvs-2.0 (08 September 20002)
+ 13 Sep 2002; phoen][x <phoenix@gentoo.org> winex-cvs-2.0.ebuild :
+
+ Added manpage installation. This installs the manpage of wine as ${PN}.
+ Removed obsolete RDEPEND tag.
+
+ 13 Sep 2002; Dan Armak <danarmak@gentoo.org> winex-cvs-2.0.ebuild :
+
+ Fix issue discussed in comments of bug #7319 where dev-util/cvs was missing
+ from the dep list.
+
08 Sep 2002; phoen][x <phoenix@gentoo.org> winex-cvs-2.0.ebuild,
files/digest-winex-cvs-2.0, files/winex-cvs-fake_windows.tar.bz2,
files/winex-cvs-regedit, files/winex-cvs-winex :
diff --git a/app-emulation/winex-cvs/winex-cvs-2.0.ebuild b/app-emulation/winex-cvs/winex-cvs-2.0.ebuild
index e5fe3ee8b41b..50fefcea11f4 100644
--- a/app-emulation/winex-cvs/winex-cvs-2.0.ebuild
+++ b/app-emulation/winex-cvs/winex-cvs-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/winex-cvs-2.0.ebuild,v 1.2 2002/09/13 11:46:55 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/winex-cvs-2.0.ebuild,v 1.3 2002/09/13 14:51:07 phoenix Exp $
# Dont modify the ECVS_BRANCH setting yourself.
# Instead, make a backup of this ebuild and rename it to
@@ -17,7 +17,6 @@ ECVS_SERVER="cvs.winex.sourceforge.net:/cvsroot/winex"
ECVS_MODULE="wine"
ECVS_BRANCH=${PN/cvs/}${PV/./-}
ECVS_TOP_DIR="${DISTDIR}/cvs-src/${ECVS_BRANCH}"
-mkdir -p ${ECVS_TOP_DIR}
inherit cvs
@@ -39,8 +38,6 @@ newdepend "virtual/x11
opengl? ( virtual/opengl )
cups? ( net-print/cups )"
-RDEPEND="${DEPEND}"
-
src_compile() {
cd ${S}
local myconf
@@ -108,6 +105,12 @@ src_install () {
doins documentation/samples/system.ini
doins documentation/samples/generic.ppd
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+
+
# Remove the executable flag from those libraries.
cd ${D}/usr/lib/winex-cvs/bin
chmod a-x *.so
@@ -120,6 +123,9 @@ pkg_postinst() {
einfo "* This is a wrapper-script which will take care of everything *"
einfo "* else. If you have further questions, enhancements or patches *"
einfo "* send an email to phoenix@gentoo.org *"
+ einfo "* *"
+ einfo "* Manpage has been installed to the system. *"
+ einfo "* \"man winex-cvs\" should show it. *"
einfo "**********************************************************************"
}
diff --git a/app-emulation/winex-cvs/winex-cvs-2.1.ebuild b/app-emulation/winex-cvs/winex-cvs-2.1.ebuild
index 46c8ce5f5d83..b414621f9cc1 100644
--- a/app-emulation/winex-cvs/winex-cvs-2.1.ebuild
+++ b/app-emulation/winex-cvs/winex-cvs-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/winex-cvs-2.1.ebuild,v 1.2 2002/09/13 11:46:55 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/winex-cvs-2.1.ebuild,v 1.3 2002/09/13 14:51:07 phoenix Exp $
# Dont modify the ECVS_BRANCH setting yourself.
# Instead, make a backup of this ebuild and rename it to
@@ -17,7 +17,6 @@ ECVS_SERVER="cvs.winex.sourceforge.net:/cvsroot/winex"
ECVS_MODULE="wine"
ECVS_BRANCH=${PN/cvs/}${PV/./-}
ECVS_TOP_DIR="${DISTDIR}/cvs-src/${ECVS_BRANCH}"
-mkdir -p ${ECVS_TOP_DIR}
inherit cvs
@@ -106,6 +105,11 @@ src_install () {
doins documentation/samples/system.ini
doins documentation/samples/generic.ppd
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+
# Remove the executable flag from those libraries.
cd ${D}/usr/lib/winex-cvs/bin
chmod a-x *.so
@@ -118,6 +122,9 @@ pkg_postinst() {
einfo "* This is a wrapper-script which will take care of everything *"
einfo "* else. If you have further questions, enhancements or patches *"
einfo "* send an email to phoenix@gentoo.org *"
+ einfo "* *"
+ einfo "* Manpage has been installed to the system. *"
+ einfo "* \"man winex-cvs\" should show it. *"
einfo "**********************************************************************"
}
diff --git a/app-emulation/winex/ChangeLog b/app-emulation/winex/ChangeLog
index 60409c379905..a19b66feb091 100644
--- a/app-emulation/winex/ChangeLog
+++ b/app-emulation/winex/ChangeLog
@@ -1,23 +1,32 @@
# ChangeLog for app-emulation/wine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/ChangeLog,v 1.11 2002/09/04 06:06:23 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/ChangeLog,v 1.12 2002/09/13 14:49:38 phoenix Exp $
+
+*winex-20020807-r1 (13 Sep 2002)
+
+ 13 Sep 2002; phoen][x <phoenix@gentoo.org> winex-20020807-r1.ebuild :
+
+ Added manpage installation. This installs the manpage of wine as ${PN}.
*winex-20020807 (19 Aug 2002)
+ 07 Sep 2002; phoen][x <phoenix@gentoo.org> winex-20020807.ebuild :
+ Renamed the regedit wrapper to "/usr/bin/regedit-winex".
+
04 Sep 2002; Nick Hadaway <raker@gentoo.org> files/81winex,
files/winex-20020807-config :
Updated LDPATH, PATH, and ROOTPATH in 81winex and added a drive H
to the default config.
+ 06 Aug 2002; phoen][x <phoenix@gentoo.org> winex-20020807.ebuild:
+ Bumped to new CVS Version (WineX 2.1). Lets hope that this
+ will fix some of the weird winex issues.
+
*winex-20020804 (04 Aug 2002)
19 August 2002; Sascha Schwabbauer <cybersystem@gentoo.org> ChangeLog, winex-20020804.ebuild :
Added -ppc to the keywords.
- 06 Aug 2002; phoen][x <phoenix@gentoo.org> winex-20020807.ebuild:
- Bumped to new CVS Version (WineX 2.1). Lets hope that this
- will fix some of the weird winex issues.
-
06 Aug 2002; phoen][x <phoenix@gentoo.org> winex-20020804.ebuild:
Fixed a typo (unset CFLAGS=""); patched tools/wineshelllink to use "winex"
instead of "wine" - Installation programs are now able to create working
diff --git a/app-emulation/winex/files/digest-winex-20020807-r1 b/app-emulation/winex/files/digest-winex-20020807-r1
new file mode 100644
index 000000000000..0d669dc87caf
--- /dev/null
+++ b/app-emulation/winex/files/digest-winex-20020807-r1
@@ -0,0 +1,2 @@
+MD5 19bb11e4b925b07cd21637d9493142f3 winex-20020807.tar.bz2 5865715
+MD5 af8da46a0e51578ff1e18e399141d628 winex-20020807-fake_windows.tar.bz2 500
diff --git a/app-emulation/winex/winex-20020807-r1.ebuild b/app-emulation/winex/winex-20020807-r1.ebuild
new file mode 100644
index 000000000000..aeed61a20a11
--- /dev/null
+++ b/app-emulation/winex/winex-20020807-r1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/winex-20020807-r1.ebuild,v 1.1 2002/09/13 14:49:38 phoenix Exp $
+
+S=${WORKDIR}/wine
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ mirror://gentoo/${P}-fake_windows.tar.bz2"
+HOMEPAGE="http://www.transgaming.com/"
+
+SLOT="0"
+KEYWORDS="x86 -ppc"
+LICENSE="Aladdin"
+
+DEPEND="virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ dev-lang/tcl dev-lang/tk"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # Azarah's patches
+ #patch -p0 < ${FILESDIR}/${P}-opengl.patch || die "opengl-patch failed"
+
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+
+ # the folks at #winehq were really angry about custom optimization
+ unset CFLAGS
+ unset CXXFLAGS
+
+ ./configure --prefix=/usr/lib/winex \
+ --sysconfdir=/etc/winex \
+ --host=${CHOST} \
+ --enable-curses \
+ --with-x \
+ ${myconf} || die "configure failed"
+
+ # Fixes a winetest issue
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ # This persuades wineshelllink that "winex" is a better loader :)
+ cd ${S}/tools
+ cp wineshelllink 1
+ sed -e 's/\(WINE_LOADER=\)\(\${WINE_LOADER:-wine}\)/\1winex/' 1 > wineshelllink
+
+ cd ${S}
+ make depend all || die "make depend all failed"
+ cd programs && emake || die "emake died"
+}
+
+src_install () {
+
+ local WINEXMAKEOPTS="prefix=${D}/usr/lib/${PN}"
+
+ # Installs winex to ${D}/usr/lib/${PN}
+ cd ${S}
+ make ${WINEXMAKEOPTS} install || die "make install failed"
+ cd ${S}/programs
+ make ${WINEXMAKEOPTS} install || die "make install failed"
+
+ # Creates /usr/lib/${PN}/.data with fake_windows in it
+ # This is needed for ~/.${PN} initialization by our
+ # winex wrapper script
+ mkdir ${D}/usr/lib/${PN}/.data
+ cp -R ${WORKDIR}/fake_windows ${D}/usr/lib/${PN}/.data
+ cp ${FILESDIR}/${P}-config ${D}/usr/lib/${PN}/.data/config
+
+ # winedefault.reg -- standard registry setup
+ cp ${WORKDIR}/wine/winedefault.reg ${D}/usr/lib/${PN}/.data/winedefault.reg
+
+ # Install the wrapper script
+ mkdir ${D}/usr/bin
+ cp ${FILESDIR}/${P}-winex ${D}/usr/bin/winex
+ cp ${FILESDIR}/${P}-regedit ${D}/usr/bin/regedit-winex
+
+ # Take care of the other stuff
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ insinto /usr/lib/winex/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/${PN}/bin
+ chmod a-x *.so
+
+}
+
+pkg_postinst() {
+ einfo "**********************************************************************"
+ einfo "* NOTE: Use /usr/bin/winex to start winex. *"
+ einfo "* This is a wrapper-script which will take care of everything *"
+ einfo "* else. If you have further questions, enhancements or patches *"
+ einfo "* send an email to phoenix@gentoo.org *"
+ einfo "* *"
+ einfo "* Manpage has been installed to the system. *"
+ einfo "* \"man winex\" should show it. *"
+ einfo "**********************************************************************"
+}
+
diff --git a/app-emulation/winex/winex-20020807.ebuild b/app-emulation/winex/winex-20020807.ebuild
index 1b48458067c4..3369248ff783 100644
--- a/app-emulation/winex/winex-20020807.ebuild
+++ b/app-emulation/winex/winex-20020807.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/winex-20020807.ebuild,v 1.2 2002/08/19 17:50:20 cybersystem Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/winex-20020807.ebuild,v 1.3 2002/09/13 14:49:38 phoenix Exp $
S=${WORKDIR}/wine
DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
@@ -83,7 +83,7 @@ src_install () {
# Install the wrapper script
mkdir ${D}/usr/bin
cp ${FILESDIR}/${P}-winex ${D}/usr/bin/winex
- cp ${FILESDIR}/${P}-regedit ${D}/usr/bin/regedit
+ cp ${FILESDIR}/${P}-regedit ${D}/usr/bin/regedit-winex
# Take care of the other stuff
cd ${S}