summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-anthy/scim-anthy-0.5.2.ebuild')
-rw-r--r--app-i18n/scim-anthy/scim-anthy-0.5.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-i18n/scim-anthy/scim-anthy-0.5.2.ebuild b/app-i18n/scim-anthy/scim-anthy-0.5.2.ebuild
new file mode 100644
index 000000000000..d4579b071e82
--- /dev/null
+++ b/app-i18n/scim-anthy/scim-anthy-0.5.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-0.5.2.ebuild,v 1.1 2005/07/18 10:22:38 usata Exp $
+
+DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/15606/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="|| ( >=app-i18n/scim-0.99.8 >=app-i18n/scim-cvs-0.99.8 )
+ || ( >=app-i18n/anthy-5900 >=app-i18n/anthy-ss-5911 )"
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc AUTHORS THANKS README
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use SCIM, you should use the following in your user startup scripts"
+ einfo "such as .gnomerc or .xinitrc:"
+ einfo
+ einfo "LANG='your_language' scim -d"
+ einfo "export XMODIFIERS=@im=SCIM"
+ einfo "export GTK_IM_MODULE=scim"
+ einfo "export QT_IM_MODULE=scim"
+ einfo
+}