summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-vrooby/lc-vrooby-0.6.65.ebuild')
-rw-r--r--app-leechcraft/lc-vrooby/lc-vrooby-0.6.65.ebuild26
1 files changed, 7 insertions, 19 deletions
diff --git a/app-leechcraft/lc-vrooby/lc-vrooby-0.6.65.ebuild b/app-leechcraft/lc-vrooby/lc-vrooby-0.6.65.ebuild
index c5c109b0c634..818dcbf60522 100644
--- a/app-leechcraft/lc-vrooby/lc-vrooby-0.6.65.ebuild
+++ b/app-leechcraft/lc-vrooby/lc-vrooby-0.6.65.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-vrooby/lc-vrooby-0.6.65.ebuild,v 1.1 2014/04/10 18:04:50 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-vrooby/lc-vrooby-0.6.65.ebuild,v 1.2 2014/07/27 16:25:30 ssuominen Exp $
EAPI="5"
@@ -9,31 +9,19 @@ inherit leechcraft
DESCRIPTION="Vrooby, removable device manager for LeechCraft."
SLOT="0"
-KEYWORDS=" ~amd64 ~x86"
-IUSE="debug udisks udisks2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
DEPEND="~app-leechcraft/lc-core-${PV}
dev-qt/qtdbus:4"
RDEPEND="${DEPEND}
- udisks? ( sys-fs/udisks:0 )
- udisks2? ( sys-fs/udisks:2 )
- "
-
-REQUIRED_USE="|| ( udisks udisks2 )"
+ sys-fs/udisks:2"
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_enable udisks VROOBY_UDISKS)
- $(cmake-utils_use_enable udisks2 VROOBY_UDISKS2)
- )
+ -DENABLE_VROOBY_UDISKS=OFF
+ -DENABLE_VROOBY_UDISKS2=ON
+ )
cmake-utils_src_configure
}
-
-pkg_postinst() {
- if use udisks2; then
- elog "You have enabled the experimental UDisks2 backend. "
- elog "Please try the old udisks:0-based one before "
- elog "reporting issues."
- fi
-}