summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/dia/dia-0.88.1-r1.ebuild')
-rw-r--r--app-office/dia/dia-0.88.1-r1.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/app-office/dia/dia-0.88.1-r1.ebuild b/app-office/dia/dia-0.88.1-r1.ebuild
index 09bd85451f16..d97398a02e2d 100644
--- a/app-office/dia/dia-0.88.1-r1.ebuild
+++ b/app-office/dia/dia-0.88.1-r1.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.88.1-r1.ebuild,v 1.10 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.88.1-r1.ebuild,v 1.11 2002/11/30 21:58:24 vapier Exp $
-IUSE="nls cups gnome bonobo"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Diagram Creation Program"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
@@ -12,6 +9,7 @@ HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
SLOT="0"
KEYWORDS="x86 ppc"
LICENSE="GPL-2"
+IUSE="nls cups gnome bonobo"
RDEPEND=">=dev-libs/libxml-1.8.15
>=media-libs/gdk-pixbuf-0.16.0-r4
@@ -24,23 +22,16 @@ DEPEND="${RDEPEND}
src_compile() {
local myconf
-
use gnome && myconf="--enable-gnome"
-
use bonobo && myconf="--enable-gnome --enable-bonobo"
-
# use python && myconf="${myconf} --with-python"
-
use nls || myconf="${myconf} --disable-nls"
-
use cups || myconf="${myconf} --disable-gnome-print"
-
- econf ${myconf} || die
+ econf ${myconf}
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
-
dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
}