summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/lyx/lyx-1.3.0.ebuild')
-rw-r--r--app-office/lyx/lyx-1.3.0.ebuild30
1 files changed, 13 insertions, 17 deletions
diff --git a/app-office/lyx/lyx-1.3.0.ebuild b/app-office/lyx/lyx-1.3.0.ebuild
index 5eeede150c6a..fafbcdd4b0aa 100644
--- a/app-office/lyx/lyx-1.3.0.ebuild
+++ b/app-office/lyx/lyx-1.3.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.0.ebuild,v 1.2 2003/02/13 09:18:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.0.ebuild,v 1.3 2003/03/01 01:13:50 vapier Exp $
-DESCRIPTION="LyX is an WYSIWYM frontend for LaTeX"
+DESCRIPTION="WYSIWYM frontend for LaTeX"
SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.gz"
HOMEPAGE="http://www.lyx.org/"
@@ -17,7 +17,6 @@ DEPEND="virtual/x11
nls? ( sys-devel/gettext )
app-text/aiksaurus
qt? ( >=x11-libs/qt-3 ) !qt? ( =x11-libs/xforms-1* )"
-
RDEPEND="${DEPEND}
app-text/ghostscript
app-text/xpdf
@@ -33,26 +32,23 @@ RDEPEND="${DEPEND}
app-text/chktex"
src_unpack() {
-
- unpack $A
- cd $S
- # patch to fix compile problem with glibc 2.3.1 from lyx 1.3.x branch cvs.
- # cf bugzilla.lyx.org #874.
- patch -p0 < $FILESDIR/$P-glibc31.diff
- patch -p0 < $FILESDIR/$P-autogen.sh.diff
- cp -f $FILESDIR/$P-configure.in $S/configure.in
-
+ unpack ${A}
+ cd ${S}
+ # patch to fix compile problem with glibc 2.3.1 from lyx 1.3.x branch cvs.
+ # cf bugzilla.lyx.org #874.
+ patch -p0 < $FILESDIR/$P-glibc31.diff
+ patch -p0 < $FILESDIR/$P-autogen.sh.diff
+ cp -f $FILESDIR/$P-configure.in $S/configure.in
}
src_compile() {
-
use nls || myconf="${myconf} --disable-nls"
if [ -n "`use qt`" ]; then
- inherit kde-functions
- set-qtdir 3
- myconf="$myconf --with-frontend=qt --with-qt-dir=${QTDIR}"
+ inherit kde-functions
+ set-qtdir 3
+ myconf="$myconf --with-frontend=qt --with-qt-dir=${QTDIR}"
else
- myconf="$myconf --with-frontend=xforms"
+ myconf="$myconf --with-frontend=xforms"
fi
[ -n "$DEBUG" ] && myconf="$myconf --enable-debug" || myconf="$myconf --disable-debug"