summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/gocr/files')
-rw-r--r--app-text/gocr/files/digest-gocr-0.40-r21
-rw-r--r--app-text/gocr/files/digest-gocr-0.443
-rw-r--r--app-text/gocr/files/gocr-0.44-makefile.patch32
3 files changed, 36 insertions, 0 deletions
diff --git a/app-text/gocr/files/digest-gocr-0.40-r2 b/app-text/gocr/files/digest-gocr-0.40-r2
index 532b9c1d24f6..1e0a9dc0df02 100644
--- a/app-text/gocr/files/digest-gocr-0.40-r2
+++ b/app-text/gocr/files/digest-gocr-0.40-r2
@@ -1,2 +1,3 @@
+MD5 13cc0d008747f5bb56d8b17be9b61859 gocr-0.40.tar.gz 780744
RMD160 1e34277b7d923706789d6e5c85996968d8506427 gocr-0.40.tar.gz 780744
SHA256 bab419672bedbc00fc7fe1395d0eb4f9b5841c248245a8457dfd4ee1d19a6f4c gocr-0.40.tar.gz 780744
diff --git a/app-text/gocr/files/digest-gocr-0.44 b/app-text/gocr/files/digest-gocr-0.44
new file mode 100644
index 000000000000..453b4dd72570
--- /dev/null
+++ b/app-text/gocr/files/digest-gocr-0.44
@@ -0,0 +1,3 @@
+MD5 8657cb057d7836ed171b5705d5e082c8 gocr-0.44.tar.gz 827497
+RMD160 d7ba1f475416f31c2360aeba30f0ff8678b39943 gocr-0.44.tar.gz 827497
+SHA256 20d7724db4d0a724ade2b36a5e95f329a0e1c46c972f08c123b67c33173b6b4f gocr-0.44.tar.gz 827497
diff --git a/app-text/gocr/files/gocr-0.44-makefile.patch b/app-text/gocr/files/gocr-0.44-makefile.patch
new file mode 100644
index 000000000000..0361c6663aad
--- /dev/null
+++ b/app-text/gocr/files/gocr-0.44-makefile.patch
@@ -0,0 +1,32 @@
+diff -Nru gocr-0.44.orig/frontend/Makefile gocr-0.44/frontend/Makefile
+--- gocr-0.44.orig/frontend/Makefile 2001-10-28 13:45:04.000000000 +0100
++++ gocr-0.44/frontend/Makefile 2007-03-29 15:53:10.000000000 +0200
+@@ -11,5 +11,5 @@
+
+
+ gnome/Makefile: gnome/configure
+- (cd gnome;configure)
++ (cd gnome;./configure)
+
+diff -Nru gocr-0.44.orig/src/Makefile.in gocr-0.44/src/Makefile.in
+--- gocr-0.44.orig/src/Makefile.in 2006-12-13 17:00:05.000000000 +0100
++++ gocr-0.44/src/Makefile.in 2007-03-29 15:55:06.000000000 +0200
+@@ -45,7 +45,8 @@
+ CPPFLAGS=@CPPFLAGS@
+ # to see the config.h
+ CFLAGS=@CFLAGS@ $(CPPFLAGS) -I../include $(DEFS)
+-LDFLAGS=@LDFLAGS@ @LIBS@ -L.
++LDFLAGS=@LDFLAGS@
++LIBADD=@LIBS@
+ DESTDIR=@prefix@
+
+ .c.o: $(INCLUDEFILES)
+@@ -57,7 +58,7 @@
+
+ $(PROGRAM): $(LIBPGMASCLIB) gocr.o
+ # make it conform to ld --as-needed
+- $(CC) -o $@ gocr.o ./lib$(PGMASCLIB).a $(LDFLAGS)
++ $(CC) $(LDFLAGS) gocr.o ./lib$(PGMASCLIB).a $(LIBADD) -o $@
+ if test -r $(PROGRAM); then cp $@ ../bin; fi
+
+ gocr.o: gocr.h Makefile