summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/namazu/namazu-2.0.21.ebuild')
-rw-r--r--app-text/namazu/namazu-2.0.21.ebuild34
1 files changed, 17 insertions, 17 deletions
diff --git a/app-text/namazu/namazu-2.0.21.ebuild b/app-text/namazu/namazu-2.0.21.ebuild
index 8da43264c5d7..d16a85234343 100644
--- a/app-text/namazu/namazu-2.0.21.ebuild
+++ b/app-text/namazu/namazu-2.0.21.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/namazu/namazu-2.0.21.ebuild,v 1.4 2012/06/09 19:00:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/namazu/namazu-2.0.21.ebuild,v 1.5 2013/08/03 06:38:13 hattya Exp $
-inherit eutils elisp-common
+EAPI="5"
-IUSE="emacs nls tk linguas_ja"
+inherit eutils elisp-common
DESCRIPTION="Namazu is a full-text search engine"
HOMEPAGE="http://www.namazu.org/"
SRC_URI="http://www.namazu.org/stable/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="emacs nls tk linguas_ja"
RDEPEND=">=dev-perl/File-MMagic-1.20
emacs? ( virtual/emacs )
@@ -34,16 +35,13 @@ RDEPEND=">=dev-perl/File-MMagic-1.20
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${PN}-2.0.19-gentoo.patch"
epatch "${FILESDIR}/${PN}-2.0.21-search.patch"
}
-src_compile() {
+src_configure() {
local myconf
-
use tk && myconf="--with-namazu=/usr/bin/namazu
--with-mknmz=/usr/bin/mknmz
--with-indexdir=/var/lib/namazu/index"
@@ -51,24 +49,26 @@ src_compile() {
econf \
$(use_enable nls) \
$(use_enable tk tknamazu) \
- ${myconf} || die
- emake || die
+ ${myconf}
+}
+
+src_compile() {
+ emake
if use emacs; then
cd lisp
- elisp-compile gnus-nmz-1.el namazu.el || die
+ elisp-compile gnus-nmz-1.el namazu.el
fi
}
src_install () {
- emake DESTDIR="${D}" install || die
-
+ emake DESTDIR="${D}" install
dodoc AUTHORS CREDITS ChangeLog* HACKING* NEWS README* THANKS TODO etc/*.png
dohtml -r doc/*
if use emacs; then
- elisp-install ${PN} lisp/gnus-nmz-1.el* lisp/namazu.el* || die
- elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el || die
+ elisp-install ${PN} lisp/gnus-nmz-1.el* lisp/namazu.el*
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
docinto lisp
dodoc lisp/ChangeLog*