summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/passivetex/passivetex-1.4-r1.ebuild')
-rw-r--r--app-text/passivetex/passivetex-1.4-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/passivetex/passivetex-1.4-r1.ebuild b/app-text/passivetex/passivetex-1.4-r1.ebuild
new file mode 100644
index 000000000000..fad78ff6e60b
--- /dev/null
+++ b/app-text/passivetex/passivetex-1.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/passivetex/passivetex-1.4-r1.ebuild,v 1.1 2004/02/01 14:14:26 usata Exp $
+
+S=${WORKDIR}
+DESCRIPTION="A namespace-aware XML parser written in Tex"
+SRC_URI="http://users.ox.ac.uk/~rahtz/passivetex/${PN}.zip"
+HOMEPAGE="http://users.ox.ac.uk/~rahtz/passivetex/"
+LICENSE="freedist"
+
+KEYWORDS="~x86 ~sparc"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/tetex
+ dev-tex/xmltex"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+
+ unpack ${A}
+ rm -f Makefile
+ cp ${FILESDIR}/${P}-Makefile Makefile
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+}
+
+pkg_postinst() {
+
+ [ -e /usr/bin/mktexlsr ] && /usr/bin/mktexlsr
+
+}