summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mysql/mysql-4.1.14.ebuild')
-rw-r--r--dev-db/mysql/mysql-4.1.14.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-db/mysql/mysql-4.1.14.ebuild b/dev-db/mysql/mysql-4.1.14.ebuild
index b558d0d0185d..bcd6c6b4ee23 100644
--- a/dev-db/mysql/mysql-4.1.14.ebuild
+++ b/dev-db/mysql/mysql-4.1.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.14.ebuild,v 1.2 2005/09/09 11:42:28 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.14.ebuild,v 1.3 2005/09/11 16:30:54 vivo Exp $
inherit eutils flag-o-matic versionator
@@ -473,13 +473,13 @@ pkg_config() {
einfo "permissions on it..."
einfo "Insert a password for the mysql 'root' user"
- ewarn "the password will be visible on the screen"
+ ewarn "Avoid [\"'\\_%] characters in the password"
- echo -n " >" && read -r pwd1
+ read -rsp " >" pwd1 ; echo
einfo "Check the password"
- echo -n " >" && read -r pwd2
+ read -rsp " >" pwd2 ; echo
- if (( pwd1 != pwd2 )) ; then
+ if [[ pwd1 != pwd2 ]] ; then
die "Passwords are not the same"
fi