summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql/postgresql-7.2-r3.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-7.2-r3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-db/postgresql/postgresql-7.2-r3.ebuild b/dev-db/postgresql/postgresql-7.2-r3.ebuild
index 9e6c3707ac0a..e3a09a080622 100644
--- a/dev-db/postgresql/postgresql-7.2-r3.ebuild
+++ b/dev-db/postgresql/postgresql-7.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.2-r3.ebuild,v 1.7 2002/07/11 06:30:19 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.2-r3.ebuild,v 1.8 2002/07/12 16:44:18 rphillips Exp $
S=${WORKDIR}/${P}
DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
@@ -158,7 +158,7 @@ pkg_config() {
echo -n "A postgres data directory already exists from version "; cat /var/lib/postgresql/data/PG_VERSION
echo "Read the documentation to check how to upgrade to version ${PV}."
else
- su - postgres -c "/usr/bin/initdb --pgdata /var/lib/postgresql/data"
+ setuidgid postgres /usr/bin/initdb --pgdata /var/lib/postgresql/data
fi
}