summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild')
-rw-r--r--dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild b/dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild
index e9cf0da6935d..be7615c3a89b 100644
--- a/dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild
+++ b/dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild,v 1.6 2011/11/18 16:41:38 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea/icedtea-6.1.10.4-r1.ebuild,v 1.7 2011/11/18 18:11:15 sera Exp $
# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
# *********************************************************
@@ -269,7 +269,9 @@ src_install() {
# Set PaX markings on all JDK/JRE executables to allow code-generation on
# the heap by the JIT compiler.
- pax-mark m $(list-paxables "${ddest}"{,/jre}/bin/*)
+ local marks="m"
+ use x86 && marks="msp"
+ pax-mark ${marks} $(list-paxables "${ddest}"{,/jre}/bin/*)
dodoc ASSEMBLY_EXCEPTION THIRD_PARTY_README