summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild')
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild b/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild
index c46daaac07b7..d0d1688a7078 100644
--- a/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild,v 1.2 2005/10/18 19:25:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild,v 1.3 2005/10/18 20:22:01 agriffis Exp $
inherit java eutils
@@ -24,7 +24,7 @@ SLOT="1.3"
KEYWORDS="x86 -*"
RESTRICT="fetch"
-IUSE="doc nsplugin mozilla"
+IUSE="doc browserplugin nsplugin mozilla"
# this is needed for proper operating under a PaX kernel without activated grsecurity acl
CHPAX_CONSERVATIVE_FLAGS="pemsv"
@@ -87,7 +87,9 @@ src_install() {
dodir /opt/${P}/share/
cp -a demo src.jar ${D}/opt/${P}/share/
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
install_mozilla_plugin /opt/${P}/jre/plugin/i386/ns600/libjavaplugin_oji.so
fi
@@ -98,6 +100,13 @@ pkg_postinst () {
# Set as default VM if none exists
java_pkg_postinst
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
+ fi
+
# if chpax is on the target system, set the appropriate PaX flags
# this will not hurt the binary, it modifies only unused ELF bits
# but may confuse things like AV scanners and automatic tripwire