summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/argtable/argtable-2.13.ebuild')
-rw-r--r--dev-libs/argtable/argtable-2.13.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/dev-libs/argtable/argtable-2.13.ebuild b/dev-libs/argtable/argtable-2.13.ebuild
index 9533a6103b45..e033d8887d90 100644
--- a/dev-libs/argtable/argtable-2.13.ebuild
+++ b/dev-libs/argtable/argtable-2.13.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/argtable/argtable-2.13.ebuild,v 1.1 2011/02/18 11:59:27 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/argtable/argtable-2.13.ebuild,v 1.2 2011/03/20 19:08:20 angelos Exp $
+EAPI=3
inherit versionator
DESCRIPTION="An ANSI C library for parsing GNU-style command-line options with minimal fuss"
@@ -19,26 +20,27 @@ IUSE="doc debug examples"
S="${WORKDIR}/${MY_P}"
-src_compile() {
+src_configure() {
econf $(use_enable debug)
- emake || die "build failed"
}
src_install() {
emake DESTDIR="${D}" install || die "install failed"
rm -rf "${D}"/usr/share/doc/${PN}2/
- dodoc AUTHORS ChangeLog NEWS README
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
if use doc ; then
cd "${S}/doc"
- dohtml *.html *.gif
- dodoc *.pdf *.ps
+ dohtml *.html *.gif || die "dohtml failed"
+ dodoc *.pdf *.ps || die "dodoc failed"
fi
if use examples ; then
cd "${S}/example"
docinto examples
- dodoc Makefile *.[ch] README.txt
+ dodoc Makefile *.[ch] README.txt || die "dodoc failed"
fi
+
+ find "${ED}" -name "*.la" -delete || die "failed to delete .la files"
}