summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild')
-rw-r--r--dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild b/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild
index 12277d02b216..fc750ab25f57 100644
--- a/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild
+++ b/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild,v 1.1 2011/03/04 14:59:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild,v 1.2 2011/11/13 18:56:12 vapier Exp $
inherit eutils
@@ -14,24 +14,18 @@ SRC_URI="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/${MY_P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="nocxx threads"
+IUSE="cxx threads"
DEPEND="dev-libs/libatomic_ops"
RDEPEND="${DEPEND}"
src_compile() {
sed '/Cflags/s:$:/gc:g' -i bdw-gc.pc.in || die
- local myconf="--with-libatomic-ops=yes"
- if use nocxx ; then
- myconf="${myconf} --disable-cplusplus"
- else
- myconf="${myconf} --enable-cplusplus"
- fi
-
- use threads || myconf="${myconf} --disable-threads"
-
- econf ${myconf}
+ econf \
+ --with-libatomic-ops=yes \
+ $(use_enable cxx cplusplus) \
+ $(use threads || echo --disable-threads)
emake || die
}