summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgcrypt/libgcrypt-1.4.6.ebuild')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.4.6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.4.6.ebuild b/dev-libs/libgcrypt/libgcrypt-1.4.6.ebuild
new file mode 100644
index 000000000000..65896237a82f
--- /dev/null
+++ b/dev-libs/libgcrypt/libgcrypt-1.4.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.4.6.ebuild,v 1.1 2010/07/15 22:26:17 arfrever Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="General purpose crypto library based on the code used in GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/libgcrypt/${P}.tar.bz2
+ ftp://ftp.gnupg.org/gcrypt/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/libgpg-error-1.5"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epunt_cxx
+}
+
+src_configure() {
+ # --disable-padlock-support for bug #201917
+ econf \
+ --disable-padlock-support \
+ --disable-dependency-tracking \
+ --with-pic \
+ --enable-noexecstack
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
+}