summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libtecla/libtecla-1.6.1.ebuild')
-rw-r--r--dev-libs/libtecla/libtecla-1.6.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libtecla/libtecla-1.6.1.ebuild b/dev-libs/libtecla/libtecla-1.6.1.ebuild
new file mode 100644
index 000000000000..bab1770dffa9
--- /dev/null
+++ b/dev-libs/libtecla/libtecla-1.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtecla/libtecla-1.6.1.ebuild,v 1.1 2006/01/20 17:49:57 markusle Exp $
+
+DESCRIPTION="Tecla command-line editing library"
+HOMEPAGE="http://www.astro.caltech.edu/~mcs/tecla/"
+SRC_URI="http://www.astro.caltech.edu/~mcs/tecla/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE=""
+DEPEND="virtual/libc
+ sys-libs/ncurses"
+
+S=${WORKDIR}/libtecla
+
+src_compile() {
+ # remove build directory from RPATH (see bug #119477)
+ sed -e "s|:\$\$LD_RUN_PATH:\`pwd\`||" -i Makefile.rules || \
+ die "Failed to adjust Makefile.rules"
+ econf || die
+ make || die
+}
+
+src_install() {
+ make install prefix=${D}/usr MANDIR=${D}/usr/share/man || die
+ dodoc CHANGES INSTALL LICENSE.TERMS PORTING README RELEASE.NOTES
+}