summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxml/libxml-1.8.17-r2.ebuild')
-rw-r--r--dev-libs/libxml/libxml-1.8.17-r2.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/dev-libs/libxml/libxml-1.8.17-r2.ebuild b/dev-libs/libxml/libxml-1.8.17-r2.ebuild
index d081919c3ab8..f566bbb68fc8 100644
--- a/dev-libs/libxml/libxml-1.8.17-r2.ebuild
+++ b/dev-libs/libxml/libxml-1.8.17-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml/libxml-1.8.17-r2.ebuild,v 1.26 2004/12/27 18:44:39 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml/libxml-1.8.17-r2.ebuild,v 1.27 2006/07/05 05:32:27 vapier Exp $
inherit flag-o-matic
@@ -10,12 +10,11 @@ SRC_URI="ftp://xmlsoft.org/old/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2"
SLOT="1"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
IUSE="doc"
RDEPEND=">=sys-libs/ncurses-5.2
doc? ( >=dev-util/gtk-doc-1 )"
-
DEPEND="${RDEPEND}
>=sys-libs/readline-4.1"
@@ -26,22 +25,21 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} \
+ make DESTDIR="${D}" \
BASE_DIR=/usr/share/doc \
DOC_MODULE=${PF} \
TARGET_DIR=/usr/share/doc/${PF}/html \
install || die
# This link must be fixed
- rm ${D}/usr/include/gnome-xml/libxml
+ rm "${D}"/usr/include/gnome-xml/libxml
dosym /usr/include/gnome-xml /usr/include/gnome-xml/libxml
dodoc AUTHORS ChangeLog NEWS README
}
pkg_preinst() {
- if [ -e ${ROOT}/usr/include/gnome-xml/libxml ]
- then
- rm -f ${ROOT}/usr/include/gnome-xml/libxml
+ if [[ -e ${ROOT}/usr/include/gnome-xml/libxml ]] ; then
+ rm -f "${ROOT}"/usr/include/gnome-xml/libxml
fi
}