summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/stfl/stfl-0.8.ebuild')
-rw-r--r--dev-libs/stfl/stfl-0.8.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/dev-libs/stfl/stfl-0.8.ebuild b/dev-libs/stfl/stfl-0.8.ebuild
deleted file mode 100644
index 3a064831fd99..000000000000
--- a/dev-libs/stfl/stfl-0.8.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/stfl-0.8.ebuild,v 1.2 2007/04/18 21:04:21 ticho Exp $
-
-inherit perl-module toolchain-funcs
-
-DESCRIPTION="A library which implements a curses-based widget set for text terminals"
-HOMEPAGE="http://www.clifford.at/stfl/"
-SRC_URI="http://www.clifford.at/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-
-IUSE="examples perl ruby"
-
-DEPEND="sys-libs/ncurses
- perl? ( dev-lang/swig dev-lang/perl )
- ruby? ( dev-lang/swig dev-lang/ruby )"
-
-RDEPEND="sys-libs/ncurses
- perl? ( dev-lang/perl )
- ruby? ( dev-lang/ruby )"
-
-src_unpack() {
- unpack "${A}"
- cd "${S}"
- sed -i \
- -e "s!-O0 -ggdb!!" \
- -e "s!^all:.*!all: libstfl.a!" \
- Makefile
-
- sed -i -e "s:/usr/lib/python2.4:${D}/usr/lib/python2.4:" \
- python/Makefile.snippet
-
- if ! use perl; then
- echo "FOUND_PERL5=0" >>Makefile.cfg
- fi
- if ! use ruby; then
- echo "FOUND_RUBY=0" >>Makefile.cfg
- fi
-}
-
-src_compile() {
- emake -j1 CC="$(tc-getCC)" || die "make failed"
-}
-
-src_install() {
- local exdir="/usr/share/doc/${PF}/examples"
-
- dodir /usr/lib/python2.4/lib-dynload
- emake prefix="${D}/usr" DESTDIR="${D}" install || die "make install failed"
-
- dodoc README
-
- if use examples; then
- insinto ${exdir}
- doins example.{c,stfl}
- insinto ${exdir}/python
- doins python/example.py
- if use perl; then
- insinto ${exdir}/perl
- doins perl5/example.pl
- fi
- if use ruby; then
- insinto ${exdir}/ruby
- doins ruby/example.rb
- fi
- fi
-
- fixlocalpod
-}