summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/namespace-clean/namespace-clean-0.240.0-r1.ebuild')
-rw-r--r--dev-perl/namespace-clean/namespace-clean-0.240.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/namespace-clean/namespace-clean-0.240.0-r1.ebuild b/dev-perl/namespace-clean/namespace-clean-0.240.0-r1.ebuild
new file mode 100644
index 000000000000..406c63a1757e
--- /dev/null
+++ b/dev-perl/namespace-clean/namespace-clean-0.240.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/namespace-clean/namespace-clean-0.240.0-r1.ebuild,v 1.1 2014/08/24 01:39:43 axs Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=RIBASUSHI
+MODULE_VERSION=0.24
+inherit perl-module
+
+DESCRIPTION="Keep imports and functions out of your namespace"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~ppc-aix ~x64-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/B-Hooks-EndOfScope-0.120.0
+ >=dev-perl/Package-Stash-0.220.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.310.0
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST=do