summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php5/pecl-pdo-oci/pecl-pdo-oci-1.0.ebuild')
-rw-r--r--dev-php5/pecl-pdo-oci/pecl-pdo-oci-1.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-php5/pecl-pdo-oci/pecl-pdo-oci-1.0.ebuild b/dev-php5/pecl-pdo-oci/pecl-pdo-oci-1.0.ebuild
index 00f8ce4b6efe..3a378632bf5e 100644
--- a/dev-php5/pecl-pdo-oci/pecl-pdo-oci-1.0.ebuild
+++ b/dev-php5/pecl-pdo-oci/pecl-pdo-oci-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdo-oci/pecl-pdo-oci-1.0.ebuild,v 1.7 2006/01/22 15:06:53 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdo-oci/pecl-pdo-oci-1.0.ebuild,v 1.8 2006/01/28 16:17:03 chtekk Exp $
PHP_EXT_NAME="pdo_oci"
PHP_EXT_PECL_PKG="PDO_OCI"
@@ -39,7 +39,7 @@ src_compile() {
has_php
if useq oci8-instant-client ; then
OCI8IC_PKG="`best_version dev-db/oracle-instantclient-basic`"
- OCI8IC_PKG="`printf ${OCI8IC_PKG} | sed -e 's|dev-db/oracle-instantclient-basic-||g'`"
+ OCI8IC_PKG="`printf ${OCI8IC_PKG} | sed -e 's|dev-db/oracle-instantclient-basic-||g' | sed -e 's|-r.*||g'`"
my_conf="--with-pdo-oci=instantclient,/usr,${OCI8IC_PKG}"
else
my_conf="--with-pdo-oci"