summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/beautifulsoup/beautifulsoup-3.0.8.1.ebuild')
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.0.8.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.0.8.1.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.0.8.1.ebuild
new file mode 100644
index 000000000000..ba139c2ea8b8
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-3.0.8.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.0.8.1.ebuild,v 1.1 2010/06/18 11:09:36 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="BeautifulSoup"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping."
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/ http://pypi.python.org/pypi/BeautifulSoup"
+SRC_URI="http://www.crummy.com/software/${MY_PN}/download/3.x/${MY_P}.tar.gz"
+
+LICENSE="PSF-2.3"
+SLOT="3.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!dev-python/beautifulsoup:0"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="BeautifulSoup.py BeautifulSoupTests.py"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" BeautifulSoupTests.py
+ }
+ python_execute_function testing
+}