summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activesupport/activesupport-3.2.12.ebuild')
-rw-r--r--dev-ruby/activesupport/activesupport-3.2.12.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-ruby/activesupport/activesupport-3.2.12.ebuild b/dev-ruby/activesupport/activesupport-3.2.12.ebuild
deleted file mode 100644
index 9a59d63e8d55..000000000000
--- a/dev-ruby/activesupport/activesupport-3.2.12.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.2.12.ebuild,v 1.1 2013/02/11 20:11:03 graaff Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="http://rubyforge.org/projects/activesupport/"
-SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-rails-*/${PN}"
-
-ruby_add_rdepend "
- >=dev-ruby/multi_json-1.0
- dev-ruby/i18n:0.6
- !!<dev-ruby/activesupport-3.0.11-r1:3.0"
-
-# memcache-client, nokogiri, and builder are not strictly
-# needed, but there are tests using this code.
-ruby_add_bdepend "test? (
- >=dev-ruby/memcache-client-1.5.8
- dev-ruby/nokogiri
- >=dev-ruby/builder-3.0.3:3
- >=dev-ruby/tzinfo-0.3.29
- )"
-
-# libxml is not strictly needed, there are tests using this code. jruby
-# uses a different xml implementation.
-USE_RUBY=${USE_RUBY/jruby/} ruby_add_bdepend "test? ( >=dev-ruby/libxml-2.0.0 )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
-# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-}