summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/echoe/echoe-4.2.ebuild')
-rw-r--r--dev-ruby/echoe/echoe-4.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/echoe/echoe-4.2.ebuild b/dev-ruby/echoe/echoe-4.2.ebuild
new file mode 100644
index 000000000000..78e1fbc4e7d7
--- /dev/null
+++ b/dev-ruby/echoe/echoe-4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/echoe/echoe-4.2.ebuild,v 1.1 2010/02/19 09:42:00 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README TODO"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Packaging tool that provides Rake tasks for common operations"
+HOMEPAGE="http://blog.evanweaver.com/files/doc/fauna/echoe/files/"
+
+LICENSE="AFL-3.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/highline dev-ruby/rubyforge"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.0-optional-gemcutter.patch
+}