summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/fast_gettext/fast_gettext-0.5.12.ebuild')
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-0.5.12.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/fast_gettext/fast_gettext-0.5.12.ebuild b/dev-ruby/fast_gettext/fast_gettext-0.5.12.ebuild
new file mode 100644
index 000000000000..2cff7c23c860
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-0.5.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/fast_gettext-0.5.12.ebuild,v 1.1 2011/06/17 18:05:57 graaff Exp $
+
+EAPI="4"
+
+# jruby support requires sqlite3 support for jruby.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5 x faster, 560 x less memory, simple, clean namespace (7 vs 34) and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/activerecord )"
+
+all_ruby_prepare() {
+ rm Gemfile Gemfile.lock || die
+}