summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rb-inotify/rb-inotify-0.8.5.ebuild')
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.8.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.8.5.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.8.5.ebuild
new file mode 100644
index 000000000000..7b838a81658f
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.8.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-inotify/rb-inotify-0.8.5.ebuild,v 1.1 2011/06/03 09:08:58 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI."
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ffi"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"