summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/samuel/samuel-0.3.3.ebuild')
-rw-r--r--dev-ruby/samuel/samuel-0.3.3.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-ruby/samuel/samuel-0.3.3.ebuild b/dev-ruby/samuel/samuel-0.3.3.ebuild
index cf64f8e48ec9..05978bc65ef1 100644
--- a/dev-ruby/samuel/samuel-0.3.3.ebuild
+++ b/dev-ruby/samuel/samuel-0.3.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/samuel/samuel-0.3.3.ebuild,v 1.3 2013/01/15 07:09:22 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/samuel/samuel-0.3.3.ebuild,v 1.4 2013/11/17 13:55:23 graaff Exp $
EAPI=4
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
RUBY_FAKEGEM_TASK_DOC=""
@@ -15,7 +15,7 @@ HOMEPAGE="http://github.com/chrisk/samuel"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
IUSE=""
ruby_add_bdepend "
@@ -23,8 +23,7 @@ ruby_add_bdepend "
>=dev-ruby/shoulda-2.11.3
>=dev-ruby/fakeweb-1.3
>=dev-ruby/httpclient-2.2.3
- >=dev-ruby/mocha-0.10.0
- virtual/ruby-test-unit
+ dev-ruby/mocha:0.12
)"
all_ruby_prepare() {
@@ -35,4 +34,7 @@ all_ruby_prepare() {
# Change the default port from 8000 to 64888 to sidestep Issue #10.
# https://github.com/chrisk/samuel/issues/10
sed -i -e 's:8000:64888:g' test/*.rb || die
+
+ # Require an old enough version of mocha.
+ sed -i -e '1igem "mocha", "~> 0.12.0"' test/test_helper.rb || die
}