summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/lttng-ust/lttng-ust-2.6.0_rc2.ebuild')
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.6.0_rc2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/lttng-ust/lttng-ust-2.6.0_rc2.ebuild b/dev-util/lttng-ust/lttng-ust-2.6.0_rc2.ebuild
new file mode 100644
index 000000000000..0166a5c3a587
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.6.0_rc2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/lttng-ust/lttng-ust-2.6.0_rc2.ebuild,v 1.1 2014/11/22 00:29:04 dlan Exp $
+
+EAPI=5
+
+inherit autotools
+
+MY_P="${P/_rc/-rc}"
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-libs/userspace-rcu"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
+ fi
+ eautoreconf
+}