summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/bzr/bzr-2.5.1-r1.ebuild')
-rw-r--r--dev-vcs/bzr/bzr-2.5.1-r1.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-vcs/bzr/bzr-2.5.1-r1.ebuild b/dev-vcs/bzr/bzr-2.5.1-r1.ebuild
index 2c8b29685d33..2a1b55824680 100644
--- a/dev-vcs/bzr/bzr-2.5.1-r1.ebuild
+++ b/dev-vcs/bzr/bzr-2.5.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/bzr-2.5.1-r1.ebuild,v 1.1 2013/05/07 17:55:44 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/bzr-2.5.1-r1.ebuild,v 1.2 2013/10/27 08:42:31 mgorny Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -38,12 +38,9 @@ PATCHES=(
"${FILESDIR}/${P}-sphinx-test-failures.patch"
)
-src_compile() {
+python_configure_all() {
# Generate the locales first to avoid a race condition.
- python_export_best
- "${PYTHON}" setup.py build_mo || die
-
- distutils-r1_src_compile
+ esetup.py build_mo
}
python_compile() {