summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/aop/aop-0.6.ebuild')
-rw-r--r--games-arcade/aop/aop-0.6.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/games-arcade/aop/aop-0.6.ebuild b/games-arcade/aop/aop-0.6.ebuild
index d7008123a902..aaf306ec7f0c 100644
--- a/games-arcade/aop/aop-0.6.ebuild
+++ b/games-arcade/aop/aop-0.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/aop/aop-0.6.ebuild,v 1.14 2014/08/10 21:21:40 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/aop/aop-0.6.ebuild,v 1.15 2014/11/19 03:15:38 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit eutils games
DESCRIPTION="Ambassador of Pain is a curses based game with only 64 lines of code"
@@ -14,19 +14,20 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~x86-fbsd"
IUSE=""
-DEPEND="sys-libs/ncurses"
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
src_prepare() {
sed -i \
-e "s#/usr/local/share#${GAMES_DATADIR}#" \
- aop.c \
- || die "sed failed"
+ aop.c || die
epatch "${FILESDIR}"/${P}-as-needed.patch
}
src_install() {
- dogamesbin aop || die "dogamesbin failed"
+ dogamesbin aop
insinto "${GAMES_DATADIR}/${PN}"
- doins aop-level-*.txt || die "doins failed"
+ doins aop-level-*.txt
prepgamesdirs
}