summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/berusky/files/berusky-1.1-gentoo.patch')
-rw-r--r--games-arcade/berusky/files/berusky-1.1-gentoo.patch70
1 files changed, 70 insertions, 0 deletions
diff --git a/games-arcade/berusky/files/berusky-1.1-gentoo.patch b/games-arcade/berusky/files/berusky-1.1-gentoo.patch
new file mode 100644
index 000000000000..7a502142d496
--- /dev/null
+++ b/games-arcade/berusky/files/berusky-1.1-gentoo.patch
@@ -0,0 +1,70 @@
+--- src/defines.h.old 2007-08-28 15:40:15.000000000 +0200
++++ src/defines.h 2007-08-28 15:41:24.000000000 +0200
+@@ -382,7 +382,7 @@
+
+ #define INI_USER_DIRECTORY "~/.berusky"
+ #define INI_USER_LEVELS "~/.berusky/User"
+-#define INI_FILE_GLOBAL "/var/games/berusky/berusky.ini"
++#define INI_FILE_GLOBAL "@GENTOO_DATADIR@/berusky.ini"
+ #define INI_FILE_USER "~/.berusky/berusky.ini"
+ #define INI_FILE_LOCAL "./berusky.ini"
+
+--- berusky.ini.old 2007-08-28 15:57:56.000000000 +0200
++++ berusky.ini 2007-08-28 15:59:07.000000000 +0200
+@@ -1,9 +1,9 @@
+ # Configuration for berusky game
+
+ # Game data location
+-level_data = /usr/share/berusky/Levels
+-game_data = /usr/share/berusky/GameData
+-graphics_data = /usr/share/berusky/Graphics
++level_data = @GENTOO_DATADIR@/Levels
++game_data = @GENTOO_DATADIR@/GameData
++graphics_data = @GENTOO_DATADIR@/Graphics
+
+ # Graphics settings for game and editor
+ # game runs in 640x480
+@@ -17,7 +17,7 @@
+
+ # Game binary & tmp dir
+ # they're used by editor for "run level" command
+-game_binary = /usr/bin/berusky
++game_binary = @GENTOO_BINDIR@/berusky
+ tmp_data = /var/tmp
+
+ # Dir for users levels (it's the default level dir for level editor)
+--- Makefile.am.old 2007-08-28 17:12:18.000000000 +0200
++++ Makefile.am 2007-08-28 17:12:52.000000000 +0200
+@@ -5,8 +5,7 @@
+
+ SUBDIRS = po src data
+
+-beruskydocdir = ${prefix}/doc/berusky
+-beruskydoc_DATA = \
++EXTRA_DIST = \
+ README\
+ COPYING\
+ AUTHORS\
+@@ -15,8 +14,6 @@
+ NEWS\
+ TODO
+
+-EXTRA_DIST = $(beruskydoc_DATA)
+-
+
+
+ # Copy all the spec files. Of cource, only one is actually used.
+--- data/Makefile.am.old 2007-08-28 17:22:45.000000000 +0200
++++ data/Makefile.am 2007-08-28 17:23:09.000000000 +0200
+@@ -4,10 +4,6 @@
+ ## If you don't want it to overwrite it,
+ ## Please disable it in the Anjuta project configuration
+
+-berusky_datadir = $(prefix)/@NO_PREFIX_PACKAGE_DATA_DIR@/@PACKAGE@
+-
+-berusky_data_DATA = \
++EXTRA_DIST = \
+ berusky-data.spec\
+ berusky.spec
+-
+-EXTRA_DIST = $(berusky_data_DATA)