summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/gnocatan/gnocatan-0.8.1.16-r1.ebuild')
-rw-r--r--games-board/gnocatan/gnocatan-0.8.1.16-r1.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/games-board/gnocatan/gnocatan-0.8.1.16-r1.ebuild b/games-board/gnocatan/gnocatan-0.8.1.16-r1.ebuild
index 1d0d9925d9ec..47f8fe1ba808 100644
--- a/games-board/gnocatan/gnocatan-0.8.1.16-r1.ebuild
+++ b/games-board/gnocatan/gnocatan-0.8.1.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/gnocatan-0.8.1.16-r1.ebuild,v 1.1 2004/02/24 16:38:41 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/gnocatan-0.8.1.16-r1.ebuild,v 1.2 2004/02/29 10:20:20 vapier Exp $
inherit gnome2
@@ -8,18 +8,15 @@ DESCRIPTION="A clone of the popular board game The Settlers of Catan"
HOMEPAGE="http://gnocatan.sourceforge.net/"
SRC_URI="mirror://sourceforge/gnocatan/${P}.tar.gz"
-KEYWORDS="~x86"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86"
IUSE="nls"
DEPEND=">=gnome-base/libgnomeui-2.2*
=dev-libs/glib-1.2*
>=app-text/scrollkeeper-0.3*"
-G2CONF="${G2CONF} `use_enable nls`"
-DOCS="AUTHORS ChangeLog README"
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -31,3 +28,13 @@ src_unpack() {
cd ${S}/server
epatch ${FILESDIR}/servertrade.diff
}
+
+src_compile() {
+ export G2CONF="${G2CONF} `use_enable nls`"
+ gnome2_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README"
+ gnome2_src_install
+}