summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/kigb/kigb-1.60.ebuild')
-rw-r--r--games-emulation/kigb/kigb-1.60.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-emulation/kigb/kigb-1.60.ebuild b/games-emulation/kigb/kigb-1.60.ebuild
new file mode 100644
index 000000000000..8d6c021fa386
--- /dev/null
+++ b/games-emulation/kigb/kigb-1.60.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/kigb/kigb-1.60.ebuild,v 1.1 2004/05/30 00:54:33 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A Gameboy (GB, SGB, GBA) Emulator for Linux"
+HOMEPAGE="http://kigb.emuunlim.com"
+# No version upstream
+#SRC_URI="http://kigb.emuunlim.com/${PN}_lin.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+
+RDEPEND="virtual/glibc
+ virtual/x11
+ dev-games/hawknl"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # use the system version
+ rm -f libNL.so*
+ # wrapper script creates these in the users' home directories.
+ rm -rf cfg inp snap state rom save
+}
+
+src_install() {
+ dogamesbin "${FILESDIR}/kigb"
+ exeinto "${GAMES_PREFIX_OPT}/${PN}"
+ doexe kigb || die "doexe failed"
+ dodoc doc/*
+ prepgamesdirs
+}