summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/rott/rott-1.0.ebuild')
-rw-r--r--games-fps/rott/rott-1.0.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/games-fps/rott/rott-1.0.ebuild b/games-fps/rott/rott-1.0.ebuild
index 26a66272dde2..2a5ee9b44053 100644
--- a/games-fps/rott/rott-1.0.ebuild
+++ b/games-fps/rott/rott-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/rott-1.0.ebuild,v 1.6 2005/01/05 14:12:30 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/rott-1.0.ebuild,v 1.7 2005/09/16 01:19:49 mr_bones_ Exp $
inherit eutils games
@@ -11,32 +11,33 @@ SRC_URI="http://www.icculus.org/rott/releases/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="~ppc x86"
IUSE=""
-DEPEND="media-libs/libsdl
+RDEPEND="media-libs/libsdl
media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}/${P}/rott
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${PV}-custom-datapath.patch
+ epatch "${FILESDIR}"/${PV}-custom-datapath.patch
}
src_compile() {
make clean || die
- make EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"${GAMES_DATADIR}/${PN}/\\\"" || die
+ emake -j1 EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"${GAMES_DATADIR}/${PN}/\\\"" \
+ || die "emake failed"
}
src_install() {
- dogamesbin rott
+ dogamesbin rott || die "dogamesbin failed"
dodoc *.txt ../{README,readme.txt}
-
- cd ${WORKDIR}
- insinto ${GAMES_DATADIR}/${PN}
- doins *.dmo huntbgin.* remote1.rts
-
+ cd "${WORKDIR}"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.dmo huntbgin.* remote1.rts || die "doins failed"
prepgamesdirs
}