summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/toppler/toppler-1.1.0.ebuild')
-rw-r--r--games-puzzle/toppler/toppler-1.1.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-puzzle/toppler/toppler-1.1.0.ebuild b/games-puzzle/toppler/toppler-1.1.0.ebuild
new file mode 100644
index 000000000000..973664483231
--- /dev/null
+++ b/games-puzzle/toppler/toppler-1.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/toppler/toppler-1.1.0.ebuild,v 1.1 2004/12/14 02:43:37 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Reimplementation of Nebulous using SDL"
+HOMEPAGE="http://toppler.sourceforge.net/"
+SRC_URI="mirror://sourceforge/toppler/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+
+DEPEND=">=media-libs/libsdl-1.2.0
+ media-libs/sdl-mixer
+ sys-libs/zlib
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ egamesconf $(use_enable nls) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make \
+ DESTDIR="${D}" \
+ localedir="/usr/share/locale" \
+ install || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+ prepgamesdirs
+}