summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/wakkabox/wakkabox-1.1.0.ebuild')
-rw-r--r--games-puzzle/wakkabox/wakkabox-1.1.0.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/games-puzzle/wakkabox/wakkabox-1.1.0.ebuild b/games-puzzle/wakkabox/wakkabox-1.1.0.ebuild
index 85ffa0302c1a..af41c3754b2b 100644
--- a/games-puzzle/wakkabox/wakkabox-1.1.0.ebuild
+++ b/games-puzzle/wakkabox/wakkabox-1.1.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/wakkabox/wakkabox-1.1.0.ebuild,v 1.8 2005/10/31 08:55:43 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/wakkabox/wakkabox-1.1.0.ebuild,v 1.9 2015/02/26 23:07:52 tupone Exp $
-inherit games
+EAPI=5
+inherit eutils autotools games
DESCRIPTION="A simple block-pushing game"
HOMEPAGE="http://kenn.frap.net/wakkabox/"
@@ -14,9 +15,15 @@ KEYWORDS="ppc x86"
IUSE=""
DEPEND=">=media-libs/libsdl-1.0.1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ rm aclocal.m4
+ eautoreconf
+}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS NEWS README
+ default
prepgamesdirs
}