summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gconf/gconf-2.22.0.ebuild')
-rw-r--r--gnome-base/gconf/gconf-2.22.0.ebuild84
1 files changed, 0 insertions, 84 deletions
diff --git a/gnome-base/gconf/gconf-2.22.0.ebuild b/gnome-base/gconf/gconf-2.22.0.ebuild
deleted file mode 100644
index b09075312fa8..000000000000
--- a/gnome-base/gconf/gconf-2.22.0.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.22.0.ebuild,v 1.10 2008/11/13 19:03:14 ranger Exp $
-
-inherit eutils gnome2
-
-MY_PN=GConf
-MY_P=${MY_PN}-${PV}
-PVP=(${PV//[-\._]/ })
-
-DESCRIPTION="Gnome Configuration System and Daemon"
-HOMEPAGE="http://www.gnome.org/"
-SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd"
-IUSE="debug doc ldap"
-
-RDEPEND=">=dev-libs/glib-2.10
- >=x11-libs/gtk+-2.8.16
- >=gnome-base/orbit-2.4
- >=dev-libs/libxml2-2
- ldap? ( net-nds/openldap )"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35
- >=dev-util/pkgconfig-0.9
- doc? ( >=dev-util/gtk-doc-1 )"
-
-# FIXME : consider merging the tree (?)
-DOCS="AUTHORS ChangeLog NEWS README TODO"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- G2CONF="${G2CONF} --enable-gtk $(use_enable debug) $(use_with ldap openldap)"
- kill_gconf
-}
-
-src_unpack() {
- gnome2_src_unpack
-
- # fix bug #193442, GNOME bug #498934
- epatch "${FILESDIR}/${P}-automagic-ldap.patch"
-}
-
-src_install() {
- gnome2_src_install
-
- # hack hack
- dodir /etc/gconf/gconf.xml.mandatory
- dodir /etc/gconf/gconf.xml.defaults
- touch "${D}"/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
- touch "${D}"/etc/gconf/gconf.xml.defaults/.keep${SLOT}
-
- echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
- doenvd 50gconf || die
- dodir /root/.gconfd
-}
-
-pkg_preinst() {
- kill_gconf
-}
-
-pkg_postinst() {
- kill_gconf
-
- #change the permissions to avoid some gconf bugs
- einfo "changing permissions for gconf dirs"
- find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
-
- einfo "changing permissions for gconf files"
- find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
-}
-
-kill_gconf() {
- # This function will kill all running gconfd-2 that could be causing troubles
- if [ -x /usr/bin/gconftool-2 ]
- then
- /usr/bin/gconftool-2 --shutdown
- fi
-
- return 0
-}