summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gnome-keyring/gnome-keyring-2.20.2.ebuild')
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-2.20.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnome-base/gnome-keyring/gnome-keyring-2.20.2.ebuild b/gnome-base/gnome-keyring/gnome-keyring-2.20.2.ebuild
new file mode 100644
index 000000000000..766ce4ac9d29
--- /dev/null
+++ b/gnome-base/gnome-keyring/gnome-keyring-2.20.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-2.20.2.ebuild,v 1.1 2007/11/25 15:31:48 leio Exp $
+
+inherit gnome2 eutils pam
+
+DESCRIPTION="Password and keyring managing daemon"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc hal pam test"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6
+ >=sys-apps/dbus-1.0
+ hal? ( >=sys-apps/hal-0.5.7 )
+ pam? ( virtual/pam )
+ >=dev-libs/libgcrypt-1.2.2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ doc? ( dev-util/gtk-doc )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="$(use_enable hal) \
+ $(use_enable test tests) \
+ $(use_enable pam) \
+ $(use_with pam pam-dir $(getpam_mod_dir))"
+}