summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.14.0-optional.patch')
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.14.0-optional.patch95
1 files changed, 95 insertions, 0 deletions
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.14.0-optional.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.14.0-optional.patch
new file mode 100644
index 000000000000..a7a56b00f4a6
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.14.0-optional.patch
@@ -0,0 +1,95 @@
+From b9515b8ef35915fd1a9721e2eb6ca4e1272d0f47 Mon Sep 17 00:00:00 2001
+From: Sobhan Mohammadpour <sobhanmohammadpour1@yahoo.fr>
+Date: Tue, 10 Dec 2013 00:27:27 +0100
+Subject: [PATCH] Make colord and wacom support optional
+
+---
+ configure.ac | 35 +++++++++++++++++++++++++++++------
+ plugins/Makefile.am | 7 ++++++-
+ 2 files changed, 35 insertions(+), 7 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index c42ea8b..26ccd36 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -225,7 +225,20 @@ dnl ---------------------------------------------------------------------------
+ dnl - color
+ dnl ---------------------------------------------------------------------------
+
+-PKG_CHECK_MODULES(COLOR, [colord >= 1.0.2 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++AC_ARG_ENABLE([color],
++ AS_HELP_STRING([--disable-color],
++ [turn off color plugin]),
++ [with_color=$enableval],
++ [with_color=yes]) dnl Default value
++
++if test x$with_color = xyes; then
++ PKG_CHECK_MODULES(COLOR, [colord >= 1.0.2 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++ AC_DEFINE(HAVE_COLOR, 1, [Define if color plugin is enabled])
++fi
++AM_CONDITIONAL(WITH_COLOR, test "x$with_color" = "xyes")
++
++AC_SUBST(COLOR_CFLAGS)
++AC_SUBST(COLOR_LIBS)
+
+ dnl ---------------------------------------------------------------------------
+ dnl - datetime
+@@ -256,15 +269,25 @@ case $host_os in
+ if test "$host_cpu" = s390 -o "$host_cpu" = s390x; then
+ have_wacom=no
+ else
++ have_wacom=no
+ if test x$enable_gudev != xno; then
+- PKG_CHECK_MODULES(LIBWACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION])
+- PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst gudev-1.0 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION xorg-wacom librsvg-2.0 >= $LIBRSVG_REQUIRED_VERSION libnotify >= $LIBNOTIFY_REQUIRED_VERSION pango >= $PANGO_REQUIRED_VERSION])
+- PKG_CHECK_MODULES(WACOM_OLED, [gudev-1.0])
++ AC_ARG_ENABLE([wacom],
++ AS_HELP_STRING([--disable-wacom],
++ [turn off wacom plugin]),
++ [with_wacom=$enableval],
++ [with_wacom=no]) dnl Default value
++ if test x$with_wacom = xyes; then
++ PKG_CHECK_MODULES(LIBWACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION])
++ PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst gudev-1.0 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION xorg-wacom librsvg-2.0 >= $LIBRSVG_REQUIRED_VERSION libnotify >= $LIBNOTIFY_REQUIRED_VERSION pango >= $PANGO_REQUIRED_VERSION])
++ PKG_CHECK_MODULES(WACOM_OLED, [gudev-1.0])
++ have_wacom=yes
++ AC_DEFINE_UNQUOTED(HAVE_WACOM, 1, [Define to 1 if wacom support is available])
++ fi
++ AC_SUBST(WACOM_CFLAGS)
++ AC_SUBST(WACOM_LIBS)
+ else
+ AC_MSG_ERROR([GUdev is necessary to compile Wacom support])
+ fi
+- AC_DEFINE_UNQUOTED(HAVE_WACOM, 1, [Define to 1 if wacom support is available])
+- have_wacom=yes
+ fi
+ ;;
+ *)
+diff --git a/plugins/Makefile.am b/plugins/Makefile.am
+index 7bb01f0..7cc3655 100644
+--- a/plugins/Makefile.am
++++ b/plugins/Makefile.am
+@@ -4,7 +4,6 @@ enabled_plugins = \
+ a11y-keyboard \
+ a11y-settings \
+ clipboard \
+- color \
+ cursor \
+ datetime \
+ dummy \
+@@ -22,6 +21,12 @@ enabled_plugins = \
+
+ disabled_plugins = $(NULL)
+
++if WITH_COLOR
++enabled_plugins += color
++else
++disabled_plugins += color
++endif
++
+ if SMARTCARD_SUPPORT
+ enabled_plugins += smartcard
+ else
+--
+2.1.2
+