summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kde-l10n/kde-l10n-4.4.4.ebuild')
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.4.4.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/kde-base/kde-l10n/kde-l10n-4.4.4.ebuild b/kde-base/kde-l10n/kde-l10n-4.4.4.ebuild
deleted file mode 100644
index 46e1891b969c..000000000000
--- a/kde-base/kde-l10n/kde-l10n-4.4.4.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.4.4.ebuild,v 1.4 2010/06/27 18:00:23 fauli Exp $
-
-EAPI="2"
-
-inherit kde4-base
-
-DESCRIPTION="KDE internationalization package"
-HOMEPAGE="http://www.kde.org/"
-LICENSE="GPL-2"
-
-DEPEND="
- sys-devel/gettext
-"
-RDEPEND=""
-
-KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+handbook"
-
-MY_LANGS="ar bg ca ca@valencia cs csb da de el en_GB eo es et eu
- fi fr fy ga gl gu he hi hr hu id is it ja kk km kn ko lt lv
- mai mk ml nb nds nl nn pa pl pt pt_BR ro ru si sk sl sr sv tg
- tr uk wa zh_CN zh_TW"
-
-URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
-SRC_URI=""
-
-for MY_LANG in ${MY_LANGS} ; do
- IUSE="${IUSE} linguas_${MY_LANG}"
- SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
-done
-
-S="${WORKDIR}"
-
-src_unpack() {
- local LNG DIR
- if [[ -z ${A} ]]; then
- elog
- elog "You either have the LINGUAS variable unset, or it only"
- elog "contains languages not supported by ${P}."
- elog "You won't have any additional language support."
- elog
- elog "${P} supports these language codes:"
- elog "${MY_LANGS}"
- elog
- fi
-
- # For EAPI >= 3, or if not using .tar.xz archives:
- [[ -n ${A} ]] && unpack ${A}
- cd "${S}"
-
- # add all linguas to cmake
- if [[ -n ${A} ]]; then
- for LNG in ${LINGUAS}; do
- DIR="${PN}-${LNG}-${PV}"
- if [[ -d "${DIR}" ]] ; then
- echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
- fi
- done
- fi
-}
-
-src_configure() {
- mycmakeargs="${mycmakeargs}
- $(cmake-utils_use_build handbook docs)"
- [[ -n ${A} ]] && kde4-base_src_configure
-}
-
-src_compile() {
- [[ -n ${A} ]] && kde4-base_src_compile
-}
-
-src_test() {
- [[ -n ${A} ]] && kde4-base_src_test
-}
-
-src_install() {
- [[ -n ${A} ]] && kde4-base_src_install
-}