summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdegraphics/kdegraphics-3.3.0-r2.ebuild')
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.3.0-r2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/kde-base/kdegraphics/kdegraphics-3.3.0-r2.ebuild b/kde-base/kdegraphics/kdegraphics-3.3.0-r2.ebuild
new file mode 100644
index 000000000000..6aa25e68ede6
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-3.3.0-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.3.0-r2.ebuild,v 1.1 2004/11/03 17:35:58 carlo Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE graphics-related apps"
+
+KEYWORDS="x86 ~amd64 ~ppc64 ~sparc ~ppc ~hppa"
+IUSE="gphoto2 imlib jpeg2k opengl povray scanner tetex"
+
+DEPEND="~kde-base/kdebase-${PV}
+ gphoto2? ( media-gfx/gphoto2 )
+ scanner? ( media-gfx/sane-backends )
+ dev-libs/fribidi
+ opengl? ( virtual/glut virtual/opengl )
+ imlib? ( media-libs/imlib )
+ virtual/ghostscript
+ media-libs/tiff
+ x86? ( scanner? sys-libs/libieee1284 )
+ povray? ( x86? ( media-gfx/povray ) )
+ jpeg2k? ( x86? ( media-libs/jasper ) )
+ !media-gfx/kolourpaint"
+RDEPEND="${DEPEND}
+ app-text/xpdf
+ tetex? (
+ || ( >=app-text/tetex-2
+ app-text/ptex
+ app-text/cstetex
+ app-text/dvipdfm )
+ )"
+
+src_unpack() {
+ kde_src_unpack
+ epatch ${FILESDIR}/post-3.3.0-kdegraphics_2.diff
+}
+
+src_compile() {
+
+ use gphoto2 \
+ && myconf="$myconf --with-kamera \
+ --with-gphoto2-includes=/usr/include/gphoto2 \
+ --with-gphoto2-libraries=/usr/lib/gphoto2" \
+ || myconf="$myconf --without-kamera"
+
+ use tetex && myconf="$myconf --with-system-kpathsea --with-tex-datadir=/usr/share"
+
+ use scanner || DO_NOT_COMPILE="$DO_NOT_COMPILE kooka libkscan"
+
+ use imlib \
+ && myconf="$myconf --with-imlib --with-imlib-config=/usr/bin" \
+ || myconf="$myconf --without-imlib"
+
+ kde_src_compile
+}